Multiple Mix Shaders Fail

I am having a difficult time producing results when using multiple mix shaders. I am able to mix shaders 1 too 2 times in a chain but when I am mixing the last two groups of shaders I only get a cyan colored output. Detaching either input from the last mix shader allows the last connected color to pass through and show up…even with the custom mix factor active. Is there a limit on how many shaders you can mix? Can anyone tell what I am doing wrong from the attached images? Yes I am new at this and I may be taking a completely unsound approach…Thanks for your help

Without a .blend noone is going to track this image with a looking glass.

Generally pink colour means you’re missing textures. Maybe that last mix shader highlights the effect of missing texture more dominant? So I suggest checking all your texture maps.

Hmmm…understood, I need to replace the proprietary textures and post it

Will do…Thanks

I have 4 texture images (poliigon purchased so I can not post the blend yet) I used node wrangler to shift the view to each one and they all show up. I thend ran through each mix shader down the line and each would show correctly in the view. It is not until I connect both of my last two shaders to the last mix shader that I get the fail. But if I disconnect either from the last mix shader then I get an image including. Very strange… I am not super familiar with Blender so I am not sure if I can take this approach of multiple mix shaders into more mix shaders?

I’ve used mixed shaders a lot more than this, so it shouldn’t be problem (It might be a new bug though, not sure.) What happens if you unplug factor of last mix shader? Are you using seperate RGB there? Is this Eevee?

Eevee has problems with too heavy material setups. I.e. the triplanar mapping utility node would fail for me if I gave it complex inputs. The inputs on their own worked, and triplanar with simple inputs worked. This was a while back though.

Does it work in Cycles?


So the above spaghetti seems to work in Eevee, at least on the testbed. I’m routing separately to Eevee, and it looks horrible; it doesn’t like bumps, replace Aniso with Glossy (roughness is not tuned), and some custom glass is just made transparent.

So I’m not sure what causes Eevee to fail if the above works. Nested node group depth maybe? I know triplanar is using some heavy groups.

If someone told me to explain what’s going on there I would cut my wrists and start sucking to I pass out faster.

1 Like

Don’t worry, I’m not going to. That was just me trying to figure out a way to generalize “how to do any kind of weave based on a mask texture” using materials only, with some random stuff being produced. You’d be pretty much forced to use nodewrangler preview function to figure out what is going on.

Well…I tested it in Cycles and it works, In Render Mode…but not in LookDev… In Eevee, if I unplug any of the Specular, Normal, Roughness, from any of the four Principled Shader setups then it works…(less what ever I unplugged). Maybe it is a nesting group issue. I am going to try and rearrange the setup into something line CarlG has (WOW) :smiley: and see if it will work. Thank you for your replies… fyi Blender v2.80.72…Also, if I try to Bake this in Cycles it crashes

Eevee screenshot with one thing unplugged

Well, off to bugtracker you go!