Multiselect Menu


(LiquidApe) #1

I just updated one of my old add-ons for 2.58 the ‘Multiselect Menu’. Please note this addon has been merged with the Dynamic Spacebar addon as well, but I personally like the ligher version that just adds the extra options to Ctrl-tab.

–>2.58 Script Download<–

http://wiki.blender.org/uploads/c/c8/Multiselect.jpg


(Ray Tungsteen) #2

Hi LiquidApe,

That’s great, I wondered what was wrong when your old AddOn wouldn’t register. I like how comprehensive it is, the ‘double mode’ settings will be useful.

For single mode and ‘all together’ mode, I prefer to use single key shortcuts. Your script helped in understanding how to set them up: “wm.context_set_value” for first entry field of the shortcut, “tool_settings.mesh_select_mode” for the Context Attributes field, and “(True, True, True)” for the Value field, where the booleans refer to the vertex, edge and face settings. It looks easy once you know it, but it took me a while!


(RickyBlender) #3

tested it wiht Ctrl-Tab in edit mode

but when i select one choice i get an error for View ?

what’s wrong with this ?

thanks


(holyenigma74) #4

I tried it 2.58 with a build from(bat3a) graphicall.org, it shows up in the preferences menu and you can enable it but when you press Ctrl+Tab you get the old menu… (it doesn’t do anything, broken)


(ValterVB) #5

You can have the same result if you press Vertex select mode + Shift + Face select mode (for example.)
Or i missing something?


(holyenigma74) #6

CTRL-TAB Switches between Vertex Select, Edge Select, and Face Select modes.
Holding SHIFT while clicking on a mode will allow you to combine modes.

http://i55.tinypic.com/oitbwy.gif


(LiquidApe) #7

What kind of error are you getting? Are you using 2.58 or newer? What OS are you on? I’m gonna need more info.

Yup! You can shift click those options in the UI. This addon just exposes that functionality within the ctrl-tab menu (which is faster than having to shift click different selections)

From reading your posts I gather that you are using Maya Shortcut keys? If that is the case, my guess is that you are having issues with a conflicting keybinding. I’ll look into it.


(LiquidApe) #8

Ok, I updated the link in the first post. The script should now work with keymaps other than the default one. (IE. Maya).


(holyenigma74) #9

still get the old menu after enabeling it…
i deleted the old.py file, copied the new one in, even cleared the pycache…


(LiquidApe) #10

holyenigma74, could you try with an official blender build? I use graphical builds a lot also, but quite frequently they introduce bugs that are unique to the builds. I don’t have the time to support all the different situations that can occur in custom builds. If you are still seeing the problem on default builds, I’ll investigate further. (BTW, I tried to go get the bat3 build from graphical to test, but the author has taken his builds offline temporarily for some reason)


(Meta-Androcto) #11

hi, you can get b3ta’s build, press download & you get a text file.
then get the link in the text.
he is having bad timeouts getting his builds up to ga.


(LiquidApe) #12

I tested it in bat3a’s build on graphical and it works fine in both maya and default modes. Not sure what the problem is…maybe key-binding conflict with another addon?


(TVA3dfx) #13

Awesome! I installed it today and it is really cool. It worked great!!!

Thank you, Sean.

Terry


(LiquidApe) #14

Glad you dig it!