Multitexture is Crap?

I recently downloaded the newest blender and I hate it because of this problem:
Objects aren’t being sorted right. Objects act like unsorted Alpha when they have a uv on them

Thanks. . .


I believe it is possible this could’ve stemmed from the merge of the texface options into the material panels.

Check the material to make sure that you have the blending mode set to ‘opaque’ and the transparency slider disabled.

I don’t have any materials in use.


The normals could be inverted. Try going into edit mode and selecting all vertices, then use CTRL + N

That is the first thing I tried. :\

This problem doesn’t happen with materials. But, vertex paint is easier on things with no material.

I’ve also noticed that some faces disappear if there is no material, or other weird problems happen.
The solution (it’s good practice to) is to give everything a material. I have about 6 materials for an entire game, using the face-texture button means you don’t have to specify an image or texture for each object, cutting down the number of materials required. All they set is the alpha type, backface culling etc.

Vertex paint is enabled in materials by making sure the “vertex paint” checkbox is enabled. I’ve no idea what “Vertex Light” does.

I guess I will do what Sdfgeoff says. :\

Thanks for the help!