My multiplayer test

Well what a change from a year or so ago! For the longest time, no one working on multiplayer, now there are 3 groups. Thats pretty awesome. Heres a link to the little demo me and doogs have been working on:

http://www.spinheaddev.com/downloads/salukmulti.rar

In order for it to work you must have python installed and I’m pretty sure it requires blender2.36

Very alpha, very laggy, but pretty cool anyway.

controls:

WASD
left control to jump

enter to type msg enter to send

Make sure you double click on the file,

and that the keys.py and .blend are in the same dir

(beat you, NORJ)
RoNC

hi folks, was on linux, 2.34 python
worked for me, but only after I loaded the two .py files into the blend. :slight_smile: cool blend, it was fun walking of the cliff.

I’m going to be on but going to bed soon so ill be doogs-afk.

Hope to see you guys on the server! Make sure you go on saluk’s server and not mine :wink: im just up for demonstration purposes — however if saluk’s doesnt work try mine :slight_smile:

(doogs)
RonC

Oh, one more thing, if you have any suggestions on helping fix the lag, please get in touch with saluk. all help is appreciated. :slight_smile:

Bring your friends!!!

also, when it asks Human or Bot - it doesnt mean AI, it means do you want your character model to be a human or robot… We just implemented that very quickly upon our release

RonC

heh, Saluk, definitely a nice job on the coding. Of course, there’s still lag issues, and collision problems but it was a great first test.

yes and doogs nice gui and textures.

Jason Lin

Very nice job guys! It’s working quite well for me.

Cool!
Very nice job, really.
How you create the two servers? (Saluk’s playhouse and doogs rules)

Bye

You have to have twisted installed (www.twistedmatrix.com) and run the file server.py. You have to run it from the command line like so:

path o\python server.py “my cool server” 1234

where on windows path o\python is probably c:\python23\python

The server display only shows 2 servers max though. You can manually enter a server/port on the login screen.

The lag issue is due to a major flaw in my implementation, I’m currently in the process of basically rewriting it and wont be there in the next version. (Hopefully!)

Except for NorJ, right? %|

Saluk: Very cool concept, and it probably runs great for you, but it’s running at about 1/2 FPS here. It also keeps printing “PYTHON SCRIPT ERROR:”, over and over again, like this:

PYTHON SCRIPT ERROR:
PYTHON SCRIPT ERROR:
PYTHON SCRIPT ERROR:
PYTHON SCRIPT ERROR:
PYTHON SCRIPT ERROR:

etc…

I hope you can fix it. :slight_smile:

Ok, I see…
When my server is running appear in the list. But when i close the command line window the server disappear. How I can avoid this?

Lemmy that error means you need to install python 2.3 on your computer. :slight_smile:
And of course games run slow if there are python errors every frame. :stuck_out_tongue:

Oh no…
today doesn’t work yet… it is the server?

Doogs and NorJ reconciled actually:)

But anyway, there is a log.txt that will tell the real python error. If it’s import problems, it’s a python installation issue, or, if you are on linux, some people were having trouble where blender didn’t want to import keys.py from the directory. If that’s the case, you can copy keys.py into your lib/python23/ directory, and then python can import it from anywhere.

The server has tu run in a dos window I’m afraid. I don’t know how to make things run as services in windows, although it’s probably not very difficult.

My master server doesn’t handle disconnects correctly, and my computer crashed last night. I forgot to restart the server :slight_smile: But the master server thinks its still running. Oops. I just restarted the master server to clear the old server, and ran the server again. Works now.

error messeges i get:

File “OBScoreCounter”, line 5, in?
AttributeError: ‘module’ object has no attribute ‘connected’

File “controller” line 31…ect, ect

(it was covered up by my force stopped window) It just keeps repeating over and over

hope this helps

Guys, i do this:
-run the server.py on port 8001
-click on .blend file and then two windows opens: one window is a command prompt Blender.exe (DOS similar) and the other is Blender editing software.
I goes on Logon and press ‘P’ key, insert data and click on Both or other button than i entering in Virtual Space so i can see a good User Friendly label “nameserver logged on”.
But i can’t do any step. If i press Esc, i came back to editor, but in the black window (DOS similar prompt), i see this error:

PYTHON SCRIPT ERROR:
Traceback (most recent call last):
File “multi”, line 230, in ?
socket.error: (10053, ‘Software caused connection abort’)

thks
Fabio
Location, Rome

its droogs…not doogs…
clockwork orange is a great book but dont do it wrong with nadsat errors

its droogs…not doogs…

Oh, really? I don’t think so…

http://img293.imageshack.us/img293/1322/doogs2fn.png

Notice the name… %| .

And, this post is like a year old. Notice how it says 2005, not 2006. No wonder it doesn’t work.

carnabyst1983 you might be interested in this. https://blenderartists.org/forum/viewtopic.php?t=54958&postdays=0&postorder=asc&start=0
Newer, and much more lag free, but I think the server is down.

eQuilibrium, hehe, Saluk won’t be spelling doogs names wrong. %| Wonder how many years they’ve been working together already…

Jason Lin

xd…sorry i didnt notice his name was doog…i thought he was refering to clockwork orange…the main character speaks nadsat…and droog is nadsat for friend…