My severe problems with Boolean Subtraction

Hello Blender Community,

my first impression of this great, free program was: “this is a milestone”.

How smart, outright beautiful, it looks, what a great value. And with these didactical excellent learning-videos from Neal Hirsig I went much faster forward in my approach to learn Blender than I could have hoped for.

But now I am stuck, in really deep trouble with the Boolean Function.

This (in my case it is a Boolean subtraction) function reacts on my PC
completely unpredictable, in more than only one way, one could even say it reacts completely arbitrary.

Normally I have two meshes. The MAIN-MESH and a second mesh
I call BAR-MESH. I know that I have to compress both meshes to a certain degree before any boolean operation can take place, I do this
with the “subdivide”-function in EDIT-Mode. Ok.

Then in Object-mode I click on the main mesh, then I click on “object
modifiers” (its symbol is a spanner or wrench), then “Add Modifier”, then “Boolean”, then I change the option from “Intersect” to “Difference”, and then, under “OBJECT:” on the right side I finally choose my BAR-MESH and then -

the unpredictable arbitrary action starts.

Before I go into the details: To add to the confusion: Yes, I had success more than once. That means the program worked the first step so that I finally could click on “Apply” and the procedure was completed, that means that the BAR-MESH which was placed inside the MAIN-MESH was indeed subtracted successfully and the result could even be saved.

But with the next mesh the next time it simply does not work. And please believe me, I have tried it over and over again more than 100 times, often by rebooting the system and not only starting Blender anew. I have a routine for this Boolean operation now, I almost could do it blindfolded.

  1. Either the program shows a black screen with the sand-clock running.
    This goes for 5 minutes and finally forces me to break the frozen system.

  2. Or, most annoying, after the second step (“Apply”) the MAIN-MESH is simply deleted and on the work-space there is only the BAR-MESH left.

  3. Or, the third possibility, after the second step (“Apply”) the MAIN-MESH and the BAR-MESH are joined together (not subtracted) to one mesh. If I then move this fusioned piece, suddenly there appears a copy or a second version of the BAR-MESH as one standalone duplicate.

These are the three main reactions and even though I replicated this procedure for about 100 times I cannot recognize a pattern why it reacts so different and so unpredictable every time.

It starts with the first step. Under “OBJECT:” I choose my BAR-MESH which should be subtracted. Then most of the time (not always!) it seems as if the system is frozen. In most cases only after app. 30 seconds, when I click into the work-space once then the sand-clock suddenly appears and the computer gives me (this occurs not every time) an error-message (“no return message”) on the very top of the screen. Later however it seems that this error-message is ignored by the system.

However, sometimes, often after 3 or 4 minutes waiting-time, the program has completed the task. Then, to finalise the boolean operation, I still have to click one time onto the “Apply”-Button.

The procedure evolving now is obscure and unpredictable. Sometimes, as mentioned above, the program does what I hope for but in most cases, over 90 percent, the MAIN-MESH simply vanishes comletely.

In the “SCENE”-tree in the upper right corner, however, the list shows (beside camera and lamp) still MAIN-MESH and BAR-MESH as items.

But - as a matter of fact and reality - sometimes I am even left with 2 BAR-MESHES only. My main-mesh is in most of all cases somehow replaced with a second BAR-MESH, or with an mesh which at least looks like a second BAR-MESH, even though the naming in the Scene-tree in the upper right corner has not changed.

The crucial point is: Normally you always can find roundabout ways around a bug, once you have recognized the work-pattern of the bug. Not here.

This has cost me so many nerves and so many hours now and has made me so desperate that I need to go into the garden to smash an old wooden chair there into pieces, - otherwise my swallowed rage would make me ill!

Normally I always try to overcome my software-problems myself, but this is so hard, so twisted, unlogic, unpredictable and intractable, it is really too much to solve for me alone. I am at my end now. I must surrender.

Are there any experienced users out there who have eventually experienced similar boolean problems? Thank you very much for reading this unpleasant message, I would surely prefer to send more positive news into this Forum.

With the kindest regards from Portugal I remain



Your meshes seem to have a very high number of polygons. Doing booleans with high poly models can crash blender.
Before using booleans ensure you don’t have any double vertices (W / remove doubles), and your face normals are all consistent (Ctrl+N)


Hello Richard,

thank you very much. - Yes, my meshes have a high number of Polygons, true.

You write this can crash Blender. What can I do? I worked weeks on these models
in “Sculptris” and spent literally days (still in Sculptris) reducing their polygons up
to a degree where it started to damage the models crispyness and attractivity.

I cannot reduce the mesh any further from here. And, it could happen, that my
model with 7 MB reacts insane under Blender, where my other model with 24 MB
has shown a successful boolean subtraction.

With your Screen Shot 2012-08-21 - I am not sure how to interpret it now.

Is it intended as this? Probably. I only ask since it shows only a minimal part of
the Blender Menu. I do not know what to do with it.

Of course now I will check that I have no double vertices and will search
for the respective menu (W / remove doubles) and I even will try CTRL-N.

But - your very sober answer leaves me with some fear that this problem
might be incurable. This because, you know, if I switch the machine on,
with always the same model-files, I receive different, unpredictable results,
different every time, as if the software would live and were in good or in
bad moode, depending on the weather or what, this is so bloody insecure,
I see no planning security for me. That worries me so much.

I will be back as soon as I have executed your advice. Thank you again
for your valuable help.


booleans are tricky in any 3d program really. trying to boolean a very dense mesh will lead to some pretty unpredictable results.

you might try this method that i use sometimes:
separate/cut out the part(s) of your mesh you want to boolean from your main mesh. then boolean them and re-join the to the main mesh and weld the verts. just an idea.

Consider what your computer must do to accomplish a boolean on a scultpris mesh that you spent that long on. I bet if you sat down with a pencil and tried to do the math by had it would take weeks. I would say that your computer does not have enough RAM to accomplish this task.

Try using the decimate modifier to pare down the vertex count. Then once you have the lowest vertex count that you can achieve without losing your shape, try using the boolean modifier.

I usually try to avoid Booleans, I have never had a good result using booleans with mesh modellers. In general they will take a perfectly good mesh and make it totally unworkable.

Another thing to think about here is the mess of topology that sculptris works with. Inside sculptris it works like a charm but inside of blender its rubbish. What your gonna probaly want to do is start learning about retopologizing your models out of sculptris. Or if you have a general idea of the form your model will take (good pre-planning will help) you could start with a low poly in blender, do your boolean and then export an OBJ file to work in sculptris.

Post denied. New posts are limited by number of URLs it may contain and checked if it doesn’t contain forbidden words.

retopolgize your model. add some sub surf, use boolean modifier. or use decimate modifier and then boolean modifier.