need help. mesh corrupt? 3d manipulator doesn't match with vertex.

hello, everybody.

i think,i have ruined a mesh. i have created different shapekeys and after that i have extended the mesh with more details and more vertices. when i now change into editmode, the 3d manipulator does not have the same position as the vertex i select.

only one vertex is selected. is there a way to repair this or make the cursor go back to the vertex?

there are a WILD number of reasons as to why this is… we will need to have a look at your blend file to find it out.

it can be caused by Modifiers
shape keys
origin points

and the list goes on.

this does not help. i dont think that it can be a wild number as you wrote, otherwise there would be lots of questions in the www, but there are not. this is a very special problem and i cannot make the blend file public, so i need an answer from somebody, who had this problem allready and fixed it.

Could it be that you have the manipulator position (not sure the correct term) set to 3d cursor, instead of midpoint?

thanks for the input. i have tried all buttons of the viewport with no success and also every snap option within the menue. is it even possible to set the manipulator somewhere else than at the vertex, when only one is activatet?

There’s only one reason for that, and that’s a company policy not to share any files. If that is the case, you should ask from the ones who decide on that policy. The rest is excuses. A few vertices doesn’t make a model.

From the image it looks as a ‘posed’ arm of a character, if it’s the case than the manipulator is set where the not deformed vertex is, not where the armature put it.


dont be ignorant, replies like this pisses me off.
there can be many reasons why your manipulator is off into freaking nowhere, and its hard to tell from the screenshot you provided.

i asked you to give us the blend file so we can easily examin the problem without having to go back and forward several times to figure out what your issue is.

of course my reply “did not help” as you stated. it was not ment to, im not going to write an article on all the different reasons why your manipulator is off. it would take me literally 10 seconds to figure out what your problem is by just having a look at the blend file.

its not a ““special problem””, and there are likely 10 different reasons that can cause this, which is why you dont find anything on the “www” as you call it.

nothing is “corrupted”. its just you clicking on stuff you dont know what does.

try to turn off ‘only render’ in the viewport properties? (if it’s on)

Could not agree more. Exactly my thoughts. :slight_smile:

I know this problem. It happens when you have multiple shape keys and enabled “Apply shape keys in edit mode”. I don’t know of any workarounds. Snapping also doesn’t work. multishapekeys.blend (632 KB)

So in other words Expected Behavior, I wouldn’t characteristic it as a “problem”