Need Help! Previous object hides the second object.

Hi everyone!

I am trying to model teeth for my head but I came across this problem.

As you can see the top and side view, the new plane mesh I added to build teeth is infront of the head mesh.

However, as I move around the camera, the plane mesh hides behind the head mesh whenever they overlap according to the view.

It is really irritating because I am trying to align the teeth plane for the right position but it’s impoosible because the plane just hides in the front view.

Does anyone know why this is happening?


It might be that you have ‘occlude background geometry’ switched on.
The thumbnail is from Blender v2.49b, but I hope it is still relevant. It’s at the bottom of the main window, next to select modes (vertex, line, face) in edit mode.

seems like this little icon is the occlude option for 2.5

it says…
‘Limit selection to visible (clipped with depth buffer)

but it makes no difference :frowning:


This kind of thing can be vexing.

Sometimes just going to wireframe mode will help, but it can get confusing if you have high-poly mesh. If you haven’t applied the subsurf modifier to the head, ticking the Optimal Display box in that modifier might help reduce the visual clutter.

Another thing I’ve done is join the two objects with Ctrl+J and then, move things (i.e. the teeth in this case) around in edit mode. In this case you can also hide vertices you’re not interested in, such as the back and top of the head - then you can work on the teeth from inside the head.

  • Bill

make sure that “x-ray” is not active for the head mesh.

Go to object properties then scroll down to display and check that “X-Ray” is not checked.

yeah it was the x-ray!

I have no idea why it was checked

thank you!