Need help setting up lighting and render settings


I’ve been busy trying to make a Minecraft animation using Cycles. After a few days work I managed to create my own rig which includes characters with movable bones, customisable faces and all blocks. Anyway, I set up a scene for my first animation but when I render it I get a lot of noise, even when I use 256 samples (which takes a minute per 720p frame on a GTX 760). How can I fix this without having to turn up samples to a huge numer? Do I have to change a couple of settings or is it better to use the internal renderer for Minecraft related animations. Or should I use an external renderer like Lux? I hope you guys can help me out :wink:

Current setup:

Rendering Tab


Turns into this

And this

Turns into this

For starters, try using arealamps and other built-in lamp types instead of emitters. Also, if you really need an emitter but it doesn’t produce much light, then tick off its MIS checkbox (in the material panels).