Need help to reduce file size

Before I have problem with rendering and now this…
My file size is too big - 1.06 GB!! a few things that I did to fix this:

  1. Scaling down the objects
  2. Decimate the faces
  3. Resizing image textures
  4. Checking the compress file in ‘Preferences’
  5. Cleaning up any unused meshes and data-blocks
    But the file size remains the same. Any reply is really appreciated. Here is the download link to my .blend file:

1 GB file too big for me LOL

first can you tell us about the

number of objects
verts count
how many modifiers
got any big particles or fluid sim in there ?

size of image texture ?

happy bl

Objects: 42
Verts: 5, 273, 088
Modifiers: 44
Big particles/ fluids: None
Image texture: 2000 x 1295

You can try to locate the cause by eleminating possible causes.
Delete all textures and save the file (dont overwrite your original) and check the size.
If it is still big than there is something corrupt, i would import the objects in a new file then and check again.

If the file is small after deleting textures they are the issue. How many textures you have in the file? Or it is only the one 2000x1295.

try to import all into new file

which bl version are you using ?

happy bl

I’m using Blender 3.9 version. I have 33 textures and all of them has the 2000 x 1295 size. I tried exporting the objects in .fbx file and imported it into a new project. The memory size is 376 MB but some of the textures are wrong.

Import (Import might be the wrong term use File->Append) directly into a new .blend-file, dont use another format as a step, that will make some information lost only blender uses.

Try append by selecting only the objects first, all dependencies should automaticly appended too.

I tried exporting them into .fbx and importing them into a new blend file. The memory is now 367 MB. Is that still big? And I kinda want to know what makes my previous file so big that it gets to 1.06 GB.

I assume your textures ~10Mbyte each, so x33 it gets near your value.
I cant tell why your file was so big in the first place.

Now that i checked my .fbx objects again after importing them in the new file, some of them are missing their textures. And the usual properties are gone. There are only active tool and workspace settings, object properties, physics properties, object constraint properties and object data properties.

As posted above use direct method via append, dont detour with .fbx

Found the solution for the missing textures. I go to Export > FBX > At ‘Path Mode’ change ‘Auto’ to ‘Copy’ > At ‘Limit to’ tick the ‘Selected Objects’ > Import .fbx file. And done! The properties came back. There are just some objects that needs to add textures again. The file memory is 394 MB and my pc runs faster now.

Thank you everyone for replying and solving my problems :smiley: