Need help with curve draw tool

Has anyone had any problems using the Freehand Curve Draw Tool? I have watched the tutorials and tried it time and again and I keep coming up with the same 2 issues: 1) it won’t draw on a surface and 2) the taper option won’t work. I am working with v.2.79. I don’t know if this matters but I am on an iMac 2017.

Did you check the options panel for the change to Surface?

I have the Stroke placement set to Surface. It doesn’t want to work. I also want the curve to taper to a point on the end, so I am setting the End Point at 1.00. It won’t taper. I have tried different setting in between 0 & 1.00, nothing changes. The diameter of the end of my curve stays unaffected. Here’s an example of what I’m talking about. I have the Surface selected and End Taper set to 1.00. I am trying to draw the curve onto the cube. #1 shows my settings w/ front view; #2 is the side.

Why isn’t Tablet Pressure turned on?

Does Curve Options panel come from an addon ? You should only have Curve stroke panel in Options tab.
The feature was demoed at early state as an addon but now, the feature should work without any addon.
No addon is needed since 2.78.
So, the use of old addon will provoke problem with internal feature.

1 Like

I wasn’t using the tablet.

Yes, that’s from the add-on. Are you saying that add-on is no longer useful? If so, what are folks using instead and can you point me in the direction of a tutorial for how to use it? Thank you!

You just have to add a curve objet, enter edit mode, suppress the curve and then press shift left click while drawing another one (or press Draw Curve button from Create tab of toolbar).
The Curve Stroke panel is at same position under Options Tab.
It is the same with same options. The only difference is that will work if you don’t use the addon.

And remember to uninstall the addon.

Thank you so much @zeauro and @YAFU!