Need help with nvidia and cycles.

Ok so here is my problem:
Went into user preferences/system and switched over to gpu but the device option that everyone seem to have under render is missing for me.

My videocard is MSI Nividia GTX570 twin frozr II with 1280 MB ddr5 ram which should be more than adequate to use CUDA at least according to the lists on these forums. The driver is the latest stable driver (335.23).

What am i doing wrong?

Hi, card is good, you have Cuda in user preferences/system and you can select your card?
Another user has problems to render with a GTX 780 and 335.23, the latest driver is sometimes not the best.
But I am just guessing.

Cheers, mib

Yes i have my card selected.

Hm, it is may a stupid question but did you change your “Engine” settings to Cycles?

Cheers, mib

OMG IM A COMPLETE MORON!!! Thank you very much that worked. And yet that information i couldn’t find anywhere. Guides should start with set render engine to cycles and THAN go into system and switch to gpu.

You mean you didn’t actually read the manual ? (link in the blender help menu). The the first part of the Getting Started page tells you to do precisely this !