Need help with rendering (noob)

Hi guys!
I just started using blender so I can consider myself a noob. I want to create some minecraft renders so I downloaded a rig. After I positioned the character the way I wanted, I checked out the render result. However, it looked just awful compared to other renders I saw.


What am I doing wrong? What should I do to make it look better?

Also, how can I make the render look like this? (that’s how the rig creator says it should look after rendering)

Attachments


Perhaps share your blend file with us? Unless you’ve changed the render settings, it should look the same as the rig you got.

I added the blender file as an attachment.

Attachments

MinecraftPlayer.blend (466 KB)

Have you tried with a fresh install of Blender? Download the latest .zip version for your OS (so you can run it without installing) and see how it renders there, as I can’t see any of the stuff you are when you render.

I tried this, but the same thing happens. Can this be caused by my graphics card?

Anybody? I need help with this…

Can you post a link to the place you got the rig? Or is that the file you downloaded?

The file I attached before is the exact same file I downloaded.
If you don’t believe me, here’s the link: http://www.minecraftforum.net/forums/mapping-and-modding/skins/1218618-1-1-blender-model-minecraft-player-compatible

And it does:


What puzzles me, though, is why you uploaded the original file you got from the internet, when it is in fact your own file that you’re not satisfied with? Upload your file so that we can see your material/render settings!

Quite frankly, I don’t see that much of a difference between the render you want to achieve and the one you got. So, what exactly bothers you? The artefacts (ground shadow / lines in character’s shoulder area)? The anti-aliasing?

Here’s my file:MinecraftTest.blend (544 KB)
I am not satisfied by the lines that appear near his head when rendering. As I said before I’m new to blender so I don’t know how to properly customize it. I just want my render to look at last similar to the example one, or at last to make those annoying floating lines seen near the head disappear.

your test file has none of the issues that you are asking for help with. clearly its not an issue with the model but with the scenery you have added in. if you want help you need to post the blend file that has the issues, repeatedly posting the rig is not going to help us solve your problem.

You don’t understand… I did nothing to the original rig but modifying the position of the body. That’s what I sent you. Also, I have a fresh installation of blender.

I think I got the solution! I only had to disable mip-maping in user preferences.

On your original picture, the scene has Steve with a grass plane and a sword in his hand. In the file you sent there’s only Steve, with a completely other pose.