Need some advice with fluids

Newcomer here, only installed blender few days ago. I’m trying create a vidsual concept with wine glasses getting filled up with wine (both for stills and animation), so I started learning/testing fluids, adn encountered some stubborn problems, looking around the net din’t seem to help yet.
When I ‘pour’ water into a glass, or later for testing half-sphere shaped obstacle, it refuses to fill in ti the bottom part. Upping the sim resolution doesn’t change this. Since the scene is supoosed to be wieved from the side, this is a problem. The obstacle is an UV sphere, half deleted + solidify (applied). I set the IOR of the obstacle 1 for better visibility.

Other things: I animated the inflow to quickly shrink after frame ~50 to stop the fluid, but even until frame 200 the whole things looks way too busy sloshing around, also still sticking to the side forever (set to ‘no slip’). Can this be overcome?
Also the whole thing looks just too ‘busy’ to me, it only gets more real if I apply very strong Corrective Smooth that starts to eat droplets.

+The fluid sim is set go from 0 to 4 in a 24 fps scene, yet it went on for almost 250 frames?

I am not here to rain on your parade, but computational fluid dynamics is one of the most difficult computer applications. Thinking back to my fluid mechanics courses, I am amazed that Blender can do what it does. But it is very tricky, and the fact you got this far in just a few days is pretty cool. After fifteen years of using Blender, it still takes me a few days just to get started with a fluid sim.

Given all of that, there are no general answers, but instead there are countless tweaks to be made. Specifics will help others answer your questions, as well, such as Blender version, render engine (Cycles or Eevee), or best of all, an upload of the file you are working on.

  • For instance, the bottom part not filling: it could be the geometry. A UV Sphere, for instance has 2 poles where a bunch of triangles meet at a single vertex; this can affect the calculations. Perhaps try a Round Cube, or a basic cube with an applied subdivision modifier (that is, add the modifier, then apply it so it actually changes the mesh). Or it could be optics, or domain resolution, or some small setting that needs to be enabled.

  • To stop the flow, I am not sure what you are “quickly shrinking” to try to stop the inflow of fluid. In version 2.81.16, in the physics tab for the inflow object, there is a check box in front of “Flow” which you can animate. At the first frame of the sim, hover your mouse cursor over it, and press the I-key (for “insert”). Go to the frame when you want it to stop, uncheck the box, and again hover and press the I-key.

  • I mention the version I used because this part of Blender changes dramatically over time. I had been using 2.81 up until just a couple weeks ago, and switched to 2.82.6 because it fixed a couple issues I ran into often. When I looked at the Fluid physics tab, it had completely changed from when I did a sim in 2.81 earlier this month. It will change more over the coming year as the developers implement MantaFlow.

  • As far as being “too busy,” this may be a shading issue, and have nothing to do with the physics. Creating a good shader may take as long as setting up the simulation your first time out.

  • Domain resolution may be the biggest factor in getting “realistic” results. On my admittedly old CPU, it can take 15-20 hours to bake a moderately dense domain for 10 seconds of animation.

That’s all I can think of at the moment, and I encourage to to keep at it.

I have two guesses for what the problem might be:

  • If the fluid domain doesn’t extend far enough down, it could be colliding with the edge

  • For fluid obstacles, try to make the surfaces continuous without any intersecting faces. If you’re using a solidify modifier on a UV sphere, it might cause tiny imperfections around the poles that prevent it from working. If that’s the case, try adjusting the Offset in the solidify modifier settings to make it expand outward instead of inward.

Hi, thanks for the in-depth response. I was using 2.81a, didn’t see animate button next to “flow” checkbox, so I keyframed the inflow objects to scale down to tiny point in ~8 frames. I like this solution though it makes the flow get gradual thinner like it does irl. Thanks for the keyboard shortcut advice. Domain resolution was 300 (domain is about 30*50 cm cube) videos suggest that’s high-ish, but I don’t really know.

Big thanks for the tip on newer version, I downloaded the 2.82 to try mantaflow.

Hi, everything is inside the domain, I was careful about that. I’ll try different solidify option although I also tried this with punching a smaller radius sphere out of half-sphere (boolean), and it did the same thing.

Hi, just fyi, the new mantaflow simualtion works perfectly, solves this issue.

Excellent. I’m glad to hear it.