Negative length audio track

audio
video

(deltaray) #1

Well I’ve never seen this before. I tried to load a movie with audio clip into the VSE, and the sound track loads with negative length as shown below:

The video plays find within blender after loading it and the sound plays too, but it’s a bit weird that the track is shifted out. Any reason for that? Other videos from the same camera load without issue and I don’t see any other issue with the video in another player. Below is the audio/video codec section from player’s output:

==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 56.60.100 (external)
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, floatle, 256.0 kbit/8.33% (ratio: 32002->384000)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AO: [pulse] 48000Hz 2ch floatle (4 bytes per sample)

(3pointEdit) #2

What happens when you copy and paste it further down the timeline? I have seen this before but don’t recall it being a reoccurring issue.


(deltaray) #3

Making a copy of the audio track has the same results. A track with a length of -96.

What’s weird though is that I tried using just the audio track in a blend file, then saving it and reloading it with just the audio track and it has the proper length. Very strange. At least this is just for one video file.