Neoner

Blender 3D add-on for easy creation of various neon signs, lamps, pointers, and lights.

With the “Neoner” add-on you can quick and easily convert any curve to the beautiful neon light.

Usage:

  1. Add a curve (shift + a – Curve) and form the desired shape, or add any text (shift + a – Text) to the scene.
  2. Pressing the “Make Neon” button in the add-on panel will convert the active object into a neon highlight.
  3. Add-on options allow adjusting the light color, tube thickness and location, the presence and number of holders and the background.

Demonstration video:

Current add-on version:
1.1.2.

Blender versions:
2.8x, 2.9x

Location:

“3D Viewport” window – N-panel – the “Neoner” tab

3 Likes

Doesn’t seem to like complex shapes.

Simple stellated dodecahedron is a mess after deleting only faces, converting to a curve and then creating neon without holders or wall.

love the approach and presentation! Keep it up!

Yes, it was designed for flat shapes. But just move the origin down the curves :slight_smile:

Bought the addon, it’s nice.
In case you have plans for further development, here a few suggestions;

  • Sometimes a skin modifier plus a subdiv modifier gives better results.
  • Material: mix emission with glossy shader (or principled: metal). Mix by fresnel. So it’s like a led.
  • Adjust Bloom button.

But I like the addon already, (and the price).

Thank you! I will think about this.

1 Like

Not sure what you mean by this:

“move the origin down the curves”

I’ve “moved” the origin using every option available under “Set Origin” and nothing changes.

Origin must be lower curves. Enter to edit mode, select all curves, press ‘g’ and move them up by local your object Z-axis.

Entered edit mode. Selected all curves. Pressed 'g" and moved them “up by local object Z-axis”. Exited edit mode. Added Neoner. Same result.

Maybe I’m misunderstanding what you mean when you say “Origin must be lower curves.” or how to get there.

Update:

Just tried it with a cube instead. That worked. So, am deleting original object, because I had problems generating the Neon for some reason.

Will try again.

Update:

Worked with cube, but not stellated dodec, same process.

Where do you get this mesh? I will try.

upd:
I get it from the “extra objects” add-on. It works, I think,

Tried with Icosahedron as well. That worked.

Here’s the file:

http://pasteall.org/blend/index.php?id=52519

Nothing fancy. Tried creating from Dodecahedron as well as beginning with an Icosahedron and then beveling it to a dodec, merging doubles to eliminate any, then Poking the faces, selecting the center vertices and scaling to stellate.

It works with your file. Or maybe I don’t understand your problem?

That line at the bottom, shown here, shouldn’t be there. That’s not the case when I do it with a cube or an ico.

(Unless I’m missing something.)

I’m trying to add it as a “neon” outline to the stellation. Extra lines are a problem.

Problem:

Hmm. Now I understand.
Neoner assumes that all curve loops are closed. If they aren’t it closes them to make the single curve. Like you build your shape from the single tube. I will think to make this optional in future.

In your case I think you can simple delete redundant curve segments ater executing Neoner.

Just for fun, I tried marking edges as Freestyle creases, exporting to SVG, importing (as a curve), and applying neoner, just to be consistent with the understanding that it’s intended to be 2D rather than 3D.

Had to join all the paths, move the origin as recommended, even then it was just a thick blob. So, lowered the values to 0.0000x just to thin the lines down. Still didn’t work.

So, I’m guessing there’s something considerably different between Blender curves and SVG curves.

ugggh.

Maybe svg import has some features. Another field for experiments.

Give you an idea of what I’m shooting for. Same dodec stellation using By-Gen / Hard Padding. Converted Neon to mesh and cleaned up the unnecessary lines (imperfectly).

Lots of potential if it can be expanded beyond 2d.

Yes, interesting idea! Mast be saved for future.

Updated to v. 1.1.0.

https://b3d.interplanety.org/en/blender-add-on-neoner-v-1-1-0/

  • Added simple mesh conversion to the neon (FLAT/VOLUME radio button)
  • Added some bloom preferences to the “Neoner” panel
  • Improved emission material

Updated to v. 1.1.2.

  • Fixed an error with switching dimensions to ‘3D’ in 2.91