Network Rendering in 2.5

Hi all,
Has anyone been able to get the network rendering in Blender 2.5 working? I have been trying to get it to work, but I’m confused with some of the settings. There is a setting for Master, Slave, and Client. I will only be using two computers on the network, so I’m not quite sure how I need to configure Blender.

Any help is appriciated.


I would like to know this also. Been playing with it, but haven’t got it working yet. Maybe the network rendering is not fully implemented yet?

Not sure if you guys are still looking into this but. . . .

I actually have using two computers (and also three).

First, read through the official documentation (posted Dec. 23, 2009): That should answer most of your basic questions. Now you where specifically interested in using two computers. I did what is technically a work-around that I used before with YADRA. What I did is I ran two instances of Blender on each computer. So what I did is the first instance of blender on computer one was set to run as a master, the the second instance was as a slave. Then on the second computer (the one I was working off of) I set the first instance to be a slave, and then the instance of blender that I was working in as a client. Let me try to simplify that (the num points are instances):

Computer 1

  • Master
  • Slave

Computer 2 (Work computer)

  • Slave
  • Client (My blender project)

It is a little clumsy, but it should work. Happy Blending!

Is anybody help and tell step by step what I need to do to net render on my 2 computers.
I tryed to repeat last BrikBot suggest - but this is not work - the error "invalid argument “memory2"” appears (((

Does anyone know if you can use Loki render with 2.5?


Unfortunately (well, for troubleshooting’s sake) I have had zero problems with it so far; I even added two different virtual machines and still did not have any issues. One question I do have is are you using any physics sims (i.e. particles, softbody)? They are not yet supported and might be the source of your problems.

For information’s sake (maybe it will help, though probably not), one issue I had at first was with my network/firewalls. I had to make sure that Blender was allowed full access through the firewalls on each individual computer, and I also have to set the IP addresses manually from “[default]”.


Gosh, another network rendering solution to look at! I have been using YADRA since early 2008, and on a brief inspection/test it looks like it has all the features that YADRA had been missing (bucket rendering and a gui) that I personally wanted, though web monitoring would have been nice to see. BTW, it did work with 2.5, though I did not extensively test it, which I probably will do later this week. I’ll post and let you know if I have any problems (if I remember ;)).

BTW, YADRA has also so far worked with 2.5, though considering it does not really add any features that the Blender network rendering system does not have, I would say stick with Blender’s for simplicity.

Shame on me for not noticing, but welcome to Blender Artists donovanvento! I hope a ~2 month late reply does not scare you off!

THanks for helping.
not any hard animation - simple move the default box for a shot distance for a 50 frames.

I dont understand what I need to press on the net menu
at the master blender - hit “start service”?
at the client blender - hit reload button and then “send job”?
and why at the slave blender is reload button or somthing like this, what i need to press first and why?


Are you using the official Blender 2.5 Alpha 0? I know for a fact I am, and even installed it on a Linux box to make sure it was the same in Linux (it was). If you look at the attached thumbnails, I have a different set of controls to work with. If you are using an earlier SVN build, that could very well be why you are getting errors. Anyway, if not, you can get it here.

So with what I have, I simply set each instance to what I want it to be (master, slave, client), then set additional settings, such as “Server address” (which I do have to set) or “Path”, and then press “F12” to start the instance. For the client, I set up the rendering as usual. However, the client has been a little picker so far: I have to use the “Send Job” button. Also, note that it will render how ever many frames you set for the animation, so if you want a still using the “Send Job” button, you will need to set it both start and end on that frame. Now you can alternatively just press “F12” for one frame in the client, as you would for a normal image.

Hopefully we can get this working for you!


ok THanks a lot.
It’s looks like it work (somthing rendering, and computers devide the animation for frames and do it separatly, as it ought to be works).
the problem that some mistake appears - and animatoin don’t work. I bet this is becourse I use a weeks bild of the blender - there are some mistakes maybe. I think at last release it should work.

Kind of a late follow up here, but did it work for you in the end, ne_mo?

Been lurking til now but I thought I’d post my experiences of this…

Firewall settings are critical if using with Windows Firewall - create Inbound and Outbound exception rules for Blender.exe, that or turn the Firewall off.

You have to have at least one slave, Won’t work with just a master and a client (I wrongly assumed the master would work as a slave too). Finally got it working with master and client on one machine and slave on another.

Even with this setup I can only get it to work with a brand new 2.5 .blend file. I took the starting cube, animated it a bit and managed to get that to network render but NONE of my old 2.49 files will network render. The console complains that various image files are missing but these are files I’ve never even heard of. I think they’re related to texture libraries I’ve used in the past but any scenes relating to this have long since been deleted in the files and they all render locally without issue.

Very important to save your file just before a render as it’s the saved file which gets passed over the network, not what you have open and in memory. You get the “<memory2>” error when the file hasn’t ever been saved.

I find the experience on the client difficult to follow. The wiki guide says “Render the Animation (Ctrl-F12) to gather the finished frames. Finished frames with “appear” automatically while it will pause on ongoing frames.” well for me the frames take about 10 seconds each to gather (according to the console on the client). Also, as there’s no “PLAY” button on 2.5 (WHY???), the only way I’ve found to test an animation is by running the resulting Quicktime file outside of Blender - hardly convenient but I suspect I’m just missing a trick here.??

I’ve yet to get a single frame network render to work. I click on “Send Job” but nothing ever comes back to view from the “Image” render button. Clicking on this even after I know the job should have rendered just produces a blank render window with “Network Render waiting for results” at the top.

Clicking on “Open Master Monitor” on the client just starts up Internet Explorer with my home page. Interesting but not was I was hoping for…

So all in all a fairly negative experience to date. :no:

I have posted a sort of straight-forward tutorial on my blog that explains the process. Since this is the only relevant thread I could find on the net, I thought I’d post the link here for poor souls like me who are struggling to understand.

HI, thanks, very helpful. I have it working but I don’t understand what im supposed to do with the exr files. The network render will only save as EXR, ignoring my PNG settings. I’ve always used PNG.What am i supposed to do with these blasted EXR’s i wonder.
can i convert them to png somehow or use them to oputput a uncompressed QT mov or something? Im a noob, and never fooled with an exr before.

sorry for the double post but really what id like to do is network render png frames. The exr’s ar 26mb each, way too big for my video editor to compile. I’m sure i am missing somehting obvious here, but dont see a way to change the output format of the network render.

Why don’t you PM one of them to let them know you’re here.


Of course it would work, it justs loads a .blend.

Well this time it worked.

it rendered between 2 machines and saved lovely png’s right where i wanted them.
I started fresh and followed forbescraft’s instructions to the letter and it worked fine, except i lost some textures somewhere even though i saved relative paths and packed the blend file, but i’ll figure that one out. Just glad to see png’s and quick too with the extra machine.

I can attest, this feature does work, and well, with a little practice, even for noobs.
thanks all.

Warbly, the textures may work for me because I have my folder where I keep my blends mapped as the same network drive on all of my machines. Not sure. Glad it worked for you.

]Hi guys,
I am on blender 2.54, and trying network render - for a week i’ve not been able to sort a problem Can anyone here help me out ?
I’ve got master set on a machine and begining to broadcast, the slaves and the clients can hear it, the web based master monitor shows the slaves on. But upon submitting the job… i get an error no 35 - “resource is temporarily unavailable”. Has anyone got this error ?? i’ve tried it on same machine with multiple blender instances, or on different machiens… always the same error.
Any help will be appreciated.
Thanks in advance guys.

I get that error also on the 2.53 beta