New Gimp PS CS6 Theme with icons

Hi guys,

This is a new theme for Gimp 2.8 to make it look similar to PS CS6 - In essence it’s a dark/grey theme (easy on the eyes) with CS6 styled icons for the toolbar.

I’ve included:
Theme (GTK2)
Icons (Toolbar)
Preference File
Toolbar Layout File
Splash-Screen Image
Detailed PDF about the theme and it’s installation.

Don’t forget to read the PDF, It’s got all you need to install even if you’re new to Linux.

I hope you like it, and find some use for it :slight_smile:

Nice, I don’t suppose it has auto-collapse panels does it?

In any case it looks almost as good as CS6, and a thousand times better than GIMP (so I guess that puts GIMP’s interface quality at roughly 1/1001 of Photoshop’s)

I’m puzzled: you don’t like Wilber, do you? But you nevertheless keep him above toolbar, although you can disable it :slight_smile:

Will this work on Windows?

Hi hype,

Yeah you should be able to use the theme with Windows ok, although I haven’t tested it on a MS machine - I didn’t include info in the PDF how to do it in Windows, but it’s easy enough and there are countless tutorials for that online, here’s one for example:

Good luck :wink:

I can verify this isnt working on windows, though thats only on my end. Maybe someone else had better luck.

Could you be more specific SaintHaven, maybe someone can help fix the problem?

Quite simply I followed the instructions found here and placed the file in directory with the themes. Within Gimp 2.8, I went to properties, themes, selected and applied it. After that, restarted Gimp 2.8 and there is no change at all to the theme or layout.

Add: Ok I figured it out. I didnt realize you double packed the files, had to use 7zip to get everything. Looks good. =)

Add2: I take that back. Only getting the icons to work, which look great. No luck with the layout yet. Also aside from themes color, the menu bar on top and panels to the right are all white and not fitting with the theme at all. Since my Gimp usage is limited I might be missing something on my end.

It could be a windows elementent that can’t be changed, could you provide a screenshot? and could I just varify that you’re using 2.8+ and not 2.6 :wink:

You said “no luck with the layout”, is that the layout of the icons in the Tool panel? or the layout of the whole theme?

After everything is installed, you’ll have to jig things around to suit, such as moving the panel beneath the Tool Panel to the left - thus allowing you to get a slimmer 2 column strip. the rest on the left you’ll also have to re-arrange to suit too - but it’s just a matter of dragging things around.



The worst part is this white text aspect which makes it quite hard to read UI elements.
I might be doing something wrong though, but I would like to try the version you have above since that looks ideal if one were to use gimp a bit.

Hi SaintHaven,

I thought I knew what you meant, but just needed to see to be sure :wink:

It looks like some of the GTK2 settings aren’t totally being carried over in Windows, not just the menu, but the left panels also. Either that or I haven’t set them - the latter is probably the case.

I’ve just checked online and found that some other dark themes have this issue sorted, so you should be able to fix the theme yourself. I don’t have Windows on any of my PCs, so I can’t varify what needs to be chaged exactly, but I can hopefully point you in the right direction if you’re interested:

With Notepad, open up the theme file “gtkrc” and scroll down to the areas that have the theme colours mentioned - I’ve labled most of them, but not all:

fg[NORMAL] = “#ffffff” #"#ffbc00"#"#000000"
fg[PRELIGHT] = “#ffffff” # Button-text
fg[ACTIVE] = “#000000” # Dunno
fg[SELECTED] = “#ffffff” #"#999999"
fg[INSENSITIVE] = “#272727” # Unselected Menus text

bg[NORMAL] = “#484848” # Dark Gray Background
bg[INSENSITIVE] = “#eeeeee” # dunno
bg[ACTIVE] = “#303030” # Tab Dark-unsellected
bg[PRELIGHT] = “#4a90d9” # Blue-Hightlight-menus
bg[SELECTED] = “#4a90d9” # Blue-Hightlight-Panels

base[NORMAL] = “#2b2b2b#Layer Background etc
base[ACTIVE] = “#777777
base[SELECTED] = “#495167” # Layer Selection
base[INSENSITIVE] = “#808080” # back-slider-background
base[PRELIGHT] = “#ffaaff” # dunno

text[NORMAL] = “#dddddd” # Dark Text
text[SELECTED] = “#000000
text[ACTIVE] = “#dddddd” # light text layer name
text[SELECTED] = “#999999” #"#ffffff"
text[INSENSITIVE] = “#565248

There are a few that I haven’t labeled as they didn’t appear to change anything, but this may be because they are over-ridden in my Ubuntu GTK3 theme.

I suggest you start with those and change them to something crazy, like red to clearly see what’s changed (if anything) - if you are unsure of what ‘#hex’ to use, just use trusty old Gimp to get the colour values there.

I hope that helps, let me know if you try and if so how you get on :wink:

Just touching up on this again. I tried it with a new computer that I migrated over to, and it still doesnt work. There’s probably some element missing thats telling it to display the proper colors for windows. This happens in both win 7 and win 8. The white elements just wont go away, even if I change all the color codes you mentioned.