New particles - no local forces?

Hi everyone, could somebody please lend me a hand with this one?

Suppose I want a fir branch. I create a cylinder and add a particle system on top of that.

Now, in Blender 2.45 and below, there is this setting to help bend the strands along the branch: “Force” on the “Particle motion” tab.
And in 2.46 and 2.47 the closest equivalent is “Global effects”, on the “Physics” tab (am I right?).

The problem, however, is that these effects are truly global, i.e. if I turn the cylinder,
in Blender 2.45 strands turn nicely with it, still bent along the branch (the cylinder), while in 2.46 and 2.47 they keep their direction (force being global).

I’ve tried parenting my cylinder to an Empty and turning that Empty instead. This helps - to an extent. Once you enter edit mode or change the number of particles, they
get recalculated or something and their direction changes.

Is there a way to get them to behave like in 2.45?

Attached images: fir needles in 2.45, fir needles in 2.47


I guess you’ll just have to enter edit mode. I can’t find the ReCalc button anymore.
Hey, that helped me! I had a problem like that, but didn’t know I could enter edit mode.

Actually, as I enter edit mode, my fir needles go south. Because of that I can’t actually enter edit mode, nor can I change particle system settings - provided I parent the branch to an empty, I can rotate it then, but edit mode is a no-no.

That’s why I have to avoid ReCalc no matter what. Actually, I think parenting my particle emitter to an empty as a way to avoid recalc is some sort of a glitch.

The problem is that the force is really global, and I need a local equivalent.

Well, since nobody knows how to do this in Blender > 2.45, I just have to use 2.45 for this type of thing:



Did you try pressing Set Editable when you had your particles the way you wanted them? When I try it, the particles freeze in position and don’t recalculate when I rotate the object.

Create your particles with NO forces applied.

Make editable.

Particles mode

Point select mode, select last.

Translate to desired angle.

Object mode

Duplicate and translate, rotate, scale as desired.


rawpigeon - whoo-hoo! It works! And I thought I’ve tried everything. Well, I never stated I’m smart. Sigh.

pappy - I didn’t quite get that part about “selecting last”. If that’s the last hair (needle in my case), then how do I know which is the last? And - do you mean that manipulating the last hair would change them all?

My Christmas tree is already done (had to do it in 2.45) - well, the tree itself, at least, and I don’t think it would be wise to start it from scratch in the latest version, but thank you all for the answers!