Newb color problem/question

Newb to Blender here, just getting going in 2.81a, having a problem with color management. I’m trying to migrate an old Sketchup project to Blender, which is a 3-d model of color space pulled from the Munsell renotation data. This is the way it looked last time I worked on it in Sketchup:

I ported the code and built the model from the same data in Blender, and it looks like this, with much duller colors overall (using the same RGB values):

On a further look, I noticed that entering hex RGB values into the Blender UI within materials (so not being rendered in any way, just flat color) gives distinctly different visual results than the same hex values in an online RGB color picker:

I see the note that Blender is doing some gamma correction; I’ve tried changing the Display Device settings under Scene/Color Management among sRGB, XYZ and None, but the latter two just made things even darker. I know that RGB is device-dependent and problematic, but I don’t know what a better option would be. I have RGB notations for each of the colors and I don’t want to alter them.

I know this is probably a dumb question, but is there a way to get the Blender colors to match the Sketchup colors, or at least be rendered in a way that looks similar?

do you have filmic selected in the colormanagment ? if so,then filmic is mainly used for HDR renderings with high light strength values above 1,if that make sence,to avoid color clipping ect.
if you want to render “only” the color values in a range from 0-1 then you can try to not use filmic as color transfrom,because it can be the reason to be dull,though filmic has some contrast options.

with the standart transfrom the render from 0-1 should not have the dullness.but as sayed with HDR light filmic is more or less a must have.

Filmic was selected, yes; I tried just now cycling it through the other options, but none of them changed the model’s appearance. Neither did changing the gamma, exposure, view transform, look or sequence; the only control that affected the appearance was “display device”, as I described, but changing it from sRGB just made it darker.

I know this isn’t a rendered view, but I want to be able to use the model “live” to demonstrate some color principles, so having reasonably accurate color fidelity within the Blender editor is a goal. In Sketchup, I was able to do this because it appeared the way I showed above, but at this point the colors are too flat and uniform to really be usable. In addition to the lower overall saturation, the lightness range is nowhere near as wide is it should be. In fact, they all appear very close to the same lightness, where the ones on top should be near-white and the lower cubes moving toward black.

Maybe the best would be, to upload the file, so we can have a look at whats happens.

Try these settings for your solid shade view. Lighting = Flat, Color = Material, No Shadow and No cavity.
When i did a quick color pick test off of the material in the viewport i got the same Hex value. The Shadow and cavity will make the boxes stand out more but also will shift the color ever so slightly and give you the wrong Hex value, so turning them off is better for color picking but worse for visual readability. Hope that helps.

additional,if you are in solid view,and you want that white backround like in sketchup screenshot,then select world at the backround,and change the backround color in the world tab to white.

edit. or even more simple,click on backround viewport and select the color underneath.

and to ged rid of the grid and gizmo ect, just click on the overlay button, in the row left from the viewport settings.

Really appreciate everyone’s help!

@pixelgrip, got the background white, thanks… and @Irowebot, wow, changing the lighting to flat made a huge difference! If anything, now it’s too vivid :stuck_out_tongue: The top colors look terrific:

But the lower ones are far too light… they should be almost black:

That center purple one in the lowest ring, closest to the front, should be this color:

It was created (programatically) with RGB 92, 14, 32, but Blender now shows it as 0xA24263 (162, 66, 99), so something changed wildly between creating it and its appearance here. If I re-set the color of that cube manually with the hex values #5c0e20, it does appear correct:

But doing that by hand for 1500 samples isn’t going to be practical :confused: So maybe this is going to become a scripting question soon, if it was something about the way the objects were created? I used the decimal RGB colors divided by 256 to scale them from 0 to 1, so 92 became 0.359375, etc.

I’m guessing the file’s too big to upload at about 30mb, but here’s a link to it on dropbox:

you should try the second backround option, i edit in the post above and change the worldbackround to black (0). because in the world the backround color emits light too,that you dont want for this i guess.

if you change only the viewport color to white it should not emit light.

i have tryed to open the test2 file but i coult not open it.

Black background looks nice too :slight_smile:

Just re-uploaded it… same link. It’s from blender 2.81a on OSX, if that matters.

file is working.i have a look!

i have changed the display device option to none.so it gets no gamma to the viewport applied,its linear then.

edit,i noticed that your cube mesh is overlapping towards the middle.maybe imported with to large scale or something.?the spaces between the cubes in the sketchup screen are much larger proportional to the cube size.

2 Likes

You’re a genius!! Looks great. Thanks very much for your help!

(Yes, the cubes do overlap and need some visual tweaks… now that it’s rendering, I can get to work on that. Really they should be arc slices, not cubes, and with a degree width rather than a fixed width, but that’s just banging on code. This is more than good enough to show people while I do that, though.)

Thanks again!

1 Like

That does looks great. Hey glad we could help!

2 Likes