Newb (not noob) question :)

Hey gang,

Okay, I admit, I’m a newbie and I’ve hit a snag. :confused:

What I’m working on is a simple globe and it looks fine in the IDE, but when I hit F12 to render it, for some reason it turns it’s bottom towards the camera and I get a less than appealing view of the world. (rather like a 3 year old really).

Now when I say globe, please think library globe with a lamp and bookshelves in the background, as opposed to planet with a sun and starfield in the background. I’m not too worried about the hideous black spot at the bottom since it will never be seen in the finished product anyway… well, hopefully not since that is the reason I’m writing in the first place. :smiley:

Also I know the lighting is FUBAR but this is not the actual scene, I’m just trying to get the globe model built. :slight_smile:

This is how it’s supposed to look.

And this is what happens when I render it.

Any help is greatly appreciated and I thank you in advance :slight_smile:


Your post is missing vital info such as material and texture mapping settings.

Post a link to your blend file so others can see it.

MOST IMPORTANT - pack your texture into your blend file (File / External Data menu) or no-one but you will be able to see your texture

It seems though as if you already have the Globe Unwrapped and the texture placed on it fine.
When you have the texture added, under mapping i would say to make sure you have it set to UV and flat, however that’s just a precaution and i feel pretty sure you’ve already done that because even if that wasn’t so i don’t think you would be getting that result. The next thing i would suggest is to make sure there is no animation in your scene. If the Recording button is turned on by the keys at the bottom right, it should make a key frame every time you move or interact with something.
Often times when i’m trying to render something i will position the camera in a specific place and then the render appears like the camera was somewhere else. it’s annoying but it’s because i had a key frame previously set for it to be somewhere else and so it loaded the frame with the camera back in it’s position where the key frame was and i have to go and delete that key frame/add a new one and then try again.

I’m also a bit of a noob, or atleast when it comes to texturing i am and so these would just be the simple mistakes that i run into d:
i’m sure some of the rest of the people here have the more professional guesses (:

Good luck (:

@Richard: Thank you. I wasn’t sure what information needed to be included so I took a screenshot of as much of the IDE as I could. I’m still really new at this :slight_smile:
Here is my blend file. I made sure that I packed the texture with it, and thank you again for that advice as I did not know about that either :slight_smile:

@Razc Thank you Razc, I will give that a try and let you know :slight_smile:


Changing the image mapping settings to these seems to have fixed it.

Ah ha Nathan!! Thank you so much!! That did the trick :slight_smile:


always remember if you unwrap a mesh to an image, you need to tell blender to use UV mapping, when you’re using blender internal. i am given to understand though that the cycles renderer automatically map to the UV if you use an image texture