No compatible gpus found cuda v10

Hi, i’m sorry. I’m french, and i just bought a MSI infinite with RTX 2070 to work on blender.
I’m a student worked before with a Mac.

I’m completly lost since several days, first day with windows…

Just installed the computer, and blender 2.8.


So i read a lot of topic didn’t find newest (i know that blender and nvidia finally find my answer)
so i installed CUDA TOOLKIT V10.

now what i have to do? i got the same message.
i install again Blender 2.8.

i’m a new beginner, french (so terrible with english). I made a short movie in my art school (10 min), learn alone in english, without ask for help… but now i need one…

So i don’t understand yet windows, code ect… if someone can explain me easily.

I would be so grateful…

tkx a lot, to this incredible community.

You make a complete clean installation of nvidia driver downloaded from nvidia site, you do not use Windows driver.
If you still have problems, you can see here if you find something related to the problem:"rtx"+"cuda"&"rtx"+"cuda"

Hi I just had a similar problem. After installing CUDA 10 blender stopped seeing my GPU. I solved the problem by reinstalling JUST the drivers. I don’t know if that is messing up something though but it’s a quick fix.

The CUDA toolkit is a requirement for building Blender from the sources with CUDA support. You don’t need need it to run Blender. That’s what the driver is for. You can get them directly from NVIDIA’s driver page
Anyways, having the toolkit installed shouldn’t interfere with normal operation.

Hi thank you, for your attention.

The problem, is based on i juste bought this computer.
When i downloaded Blender 2.8. My gpu was not found. (RTX 2070)

In 2.79 i can use my gpu (I used kernel_sm_75 and filter_sm_75 but in blender2.8 i don’t find 2.80/Scripts/addons/cycles/lib, i have no “lib”)

so i decided to downloaded cuda 10. But it doesn’t work too.

Since the beginning blender 2.8 doesn’t find MY CUDA GPU.

So you’re messing around with kernel files and libraries?
Any particular reason not to install the driver for your card, as we suggested?
Again CUDA Toolkit are files needed for CUDA development. They have absolutely nothing to do with the operation of your card.

I did, it works :slight_smile:

thank you so much!

1 Like

how did you get it work ? i got the same problem :confused:

Hey there. Welcome to BA!
Would you mind tell us a bit more about your setup and what you tried so far?
That will put us in a much better place to help you.

Probably he has installed proper drivers for his gpu :sweat_smile: