no faces in blender, but they appear in jme3


my apologies if this is a dumb question…
I have a model which seems to have no faces when i look at it in blender. I tried setting the viewport shading to “solid” and “texture”, and i tried to go into edit mode and select all faces, but i cant find them

But when i load it in jme3 it does seem to have faces:

This is based on an old model. In this one i can see the faces normally, and according to my colleague who worked on it the only difference between the two models should be the colours of the materials.

Any ideas what happened and how i can get the faces back?

“when i load it”, “when i open it in Blender” - “it”: can you shed some light on what is “it” what you open in blender?

Please attach or post a link to your .blend file.

Unfortunately you decided to crop your screenshot so we cannot see the header at the top of the blender interface that shows number of faces
What blender version ?

Hi eppo, thanks for your reply :slight_smile: im not sure i know how to make myself clearer though, i open the blender file.

Thanks Richard. Unfortunately, since the original work is not mine i dont dare to post the whole file.
Here is a better screenshot: