No GPU Compute Device for NVIDIA

Running Ubuntu 14.04 linux x64, Nvidia GTX 560, 331.113 driver, the libcuda1-331 library, also have cuda toolkit 5 installed although I understand it isn’t necessary. 2.72 and 2.73 versions both from build bot and stable versions not detecting card anymore. Are there any other ubuntu users experiencing this problem? Has Blender removed this option in preferences because it might be redundant if it detects the card? Is it a bug? Computer is running using nVidia driver and not nouveau. Any Ideas?

Found the answer thanks to YAFU!…vidia-modprobe
You need to install this for ubuntu 14.04 users, to get blender to recongnize your graphics card.

Awesome! Thank you!

Thank you! Works for me too.

Old laptop Pentium T2330 processor and Nvidia 8600M GS / (had Windows 7-32, just installed new UBUNTU 14.04.1 , 64bit , install with proprietary drivers v. 331.113) but just CPU available in Blender.

The link is to a driver dated July 2014, I used that.
Note that the same web page links to an Nvidia dowload site with newer versions of the same.

I was able to enable GPU from the User Preferences>System … however the pitiful old laptop card only has a compute capability of 1.1 (2 is minimum for Cycles GPU rendering)
Still maybe GPU helps in other situations?

Thanks for the link,ebutts531!I haven’t used Blender for some time, and just had the same issue today after downloading the new Blender version. To my surprise, I found out that the previous version of Blender also couldn’t detect CUDA, even though it worked before.

Installing this package fixed it!

Thank god, when searching the www I came across this thread.

So I checked my nvidia-modprobe, it’s the one recommended here and I still can’t render on my GTX560Ti on Ubuntu 14.04.

Is it really that difficult to have Cuda on Ubuntu? :confused:
Can a merciful soul help me with this?


@fahrer17, You try downloading the official version of blender or blender from buildbot, and run the “blender” file. If it still does not work, show here what you get from the terminal with:

uname -r

lspci | grep -iE ‘vga|3D’

cat /proc/driver/nvidia/version

sudo dpkg -l | grep -i nvidia


I believe that I’ve followed all of the instructions exactly but it is still not working. I obviously have 3D acceleration, but Blender 2.72b 64bit (version available in repository Ubuntu 15.04) still no cuda. Here is the info requested:

uname -r


lspci | grep -iE ‘vga|3D’

07:00.0 VGA compatible controller: NVIDIA Corporation GK110B [GeForce GTX Titan Black] (rev a1)

cat /proc/driver/nvidia/version

NVRM version: NVIDIA UNIX x86_64 Kernel Module 346.59 Tue Mar 31 14:10:31 PDT 2015
GCC version: gcc version 4.9.2 (Ubuntu 4.9.2-10ubuntu13)

sudo dpkg -l | grep -i nvidia

ii bbswitch-dkms 0.7-2ubuntu1 amd64 Interface for toggling the power on nVidia Optimus video cards
ii libcuda1-346 346.59-0ubuntu1 amd64 NVIDIA CUDA runtime library
ii nvidia-346 346.59-0ubuntu1 amd64 NVIDIA binary driver - version 346.59
ii nvidia-modprobe 340.46-1 amd64 utility to load NVIDIA kernel modules and create device nodes
ii nvidia-opencl-icd-346 346.59-0ubuntu1 amd64 NVIDIA OpenCL ICD
ii nvidia-prime 0.8.1 amd64 Tools to enable NVIDIA’s Prime
ii nvidia-settings 346.59-0ubuntu1 amd64 Tool for configuring the NVIDIA graphics driver

Any suggestions?

Thank you for any help (I really want to cut all ties to macro$lop).

Hi, Blender 2.72 does not support Titan (iirc) and the Blender from repositories does not support Cuda at all.
Download latest Blender from, use the zip version, unpack and start.
It seams all Nvidia stuff is correct so Blender with Cuda should work.

Cheers, mib

Thank you. The zipped version works but Ubuntu does not launch the version from the un-zipped file.

Being a Blender question, I am curious about if it is safe to overwrite the installed version with the un-zipped version so that the launcher will run the latest un-zipped version? I am willing to try it but I cannot afford to boink Blender installed on my system. If you know it is unsafe then I would greatly appreciate a heads up. :confused: