no manifold mesh problem

hi,
I want to export some blender model for a game, and I have try to reduce the amount of polygons from blender but in some cases I get the “no manifold mesh” error :|. I have heard that is this problem is due to the fact that some edges belong to more than two faces, but, is there any way to solve it or you have to edit the mesh and rearrange it all by hand, what could be really exhausting :o.
Thanx ;).

you have to work manually

Ouuch :o, that’s going to be very hard :(, cannot be solve with any python script? no alternative?.
ufff :-?, it’s a very big and complicated mesh.
bye :wink:

That is a really annoying bug in blender. Another way to reduce no. of vertices is to scale it down, almost to zero, but not quite, and then click remove doubles. You can’t get it perfect, but it’s better than nothing.

Ok, it will be easier if you turn off double sidedness, and work your mesh so that it is correct from all angles.

in solid mode with double sideded off the back side is black. Work you mesh so that the caluclated normals all point in the correct direction

that should help with the shared edge problem

maybe you could try this:

go in edit mode
if mesh is symetrical, cut one half off

weld near verts - w4 (remove doubles), set appropriate values first in
f9 window (0.05 is good for starters, depends on density of your mesh)

shift j - detriangulate mesh
alt f - beauty fill (if you have 223 lying around, use it instead of 225+)
combine halfs (clear interior faces and edges first)
again - weld verts w4 (actually it’s w5 in 227 - damn developers)
ctrl n - recalculate normals outside
award yourself - have a bear

such thing worked for me when importing dxf meshes from other toys

OR, ALTERNATIVELY, IF YOU ARE REALLY DETERMINED

  • set your grid units according to your preferences
    go in edit mode
    select all verts of your mesh
    snap (shift s 1) them to grid (similar to “quantize” in lightwave)
    weld duplis w4 (or w5 in f*** 227)

optionally shift j detriangulate
and alt f beauty fill (use 223 - makes more sense)
and ctrl n recalculate normals

have a coffee
you deserved it

hi again,
Finally I partially solved the problem :D, I applied tedi’s advises (also drank about fifty beers 8)) and although is not as efficient as decimator it’s a good alternative.
Thanks you all :wink:

hmmm ::::

didn’t you notice I am secret promotor of bear industry …

ach, himmel just forgot to add:

similar procedure (DON’T use alt f beauty fill !!!) works also to
get blendhar’s radio solution back in shape - works well with subD’s

which basically means you could preserve vertcolors and materials with
some planning ahead using above described technique.

http://jmsoler.free.fr/didacticiel/blender/tutor/cpl_face2segment.htm

1/ First, add uvcoord to the original mesh with fkey before to use the script.
2/ Leave FaceSelect mode.
3/ Give the name of object in the line:
o=Blender.Object.Get(‘Plane’)
4/ Alt-p on the script windows. It could be long.

A part of the result is a second mesh named “test”. It shows the edges which have to be corrected. The faces with problems are selected in the original mesh. Just return in FaceSelect mode to see them.