No OSA looking through alpha texture?

I’ve been trying to render a simple textured scene using some billboards with transparent png tree textures. However, even with OSA turned on I seem to be getting an aliasing effect on surfaces looking through the transparent portion of the billboard:

Here’s a close-up to clarify:

Is there something obvious I’m not thinking of? I’ve come across this problem several times before… :confused:

Try to use Z transp instead of Ray transp, that fixes your problem.

Problem solved - many thanks!

thanks Cipix!!! wiki updated.

Good work making a point of that in the wiki! As usual, I’ll pick nits and mention that it’s sliiiiightly incorrect. It’s a not-too-nice limitation currently in Blender’s raytracer, that it disables texture anti-aliasing on secondary ray bounces. It doesn’t actually disable OSA, if that was the case, objects in reflections/refractions would have jaggy edges too.

I dont think it’s got anything to do with Z values specifically, more like a lack of information that the renderer has at an intersection. I wonder if it could be fixed by giving the raytracer ray differentials so it knows which area of the texture is being sampled…

universial fix: render large, then size down with bicubic sampling.

Watch this:
It doesn’t solve the problem (if texture filtering is needed) but at least looks seamless.
Changed texture interpolation filter size to 0.100

thx broken and Agent AL. wiki updated. better?

Is this also an issue with the node-based compositor? Are Z values returned for the tree plane, not the ground behind it? It would be nice if Alpha value of 0.0 brought a Z for the stuff behind it, as this is a DOF issue as well and all those nodes that use Z.

Z values are returned for geometry yes, regardless of alpha value. It would be nice to have the Z values, ‘see-through’, but I don’t know how difficult that would be…