No shadows in 3d view,but on game engine

Hi.i am experiencing a problem with realtime shadows,in 3d view i see no shadows,but when i start the game shadows are visible…How can i fix this…i really need them to show in 3d view.

Thank you.

Add a material to the plane. [by default no material is assigned to newly created objects] .=.

You can see shadows if ou select textured view mode and select ‘GLSL’ in the properties (N) / display settings.
If your lights are set to have buffer shadows you will see the shadows they cast in the 3d view.

I know all this stuff already(yeah glsl on,texture mode on,and materials) the spot works for a limited time…it works fine until I append my player set up to main scene… After I append no more 3d view shadows…but I see them when game engine on.