No "use nodes" option! Help!

I am new to the whole Compositor in Blender, and I can’t seem to find the “use nodes”. Only when I add an object, but then I don’t get the RenderLayers node, only a Material node.

At the header across the bottom, there are three icons. One for material, one for texture, and one for composite nodes. Choose that one, then you should see the option for Use Nodes.

Thank you. But what if I have already added some objects and I want to use renderlayers, not material nodes, how do I change that? I can’t seem to find “renderlayers” anywhere, unless I start from complete scratch and turn on “use nodes” at the start of my modelling/whatever I am doing.

Change to Composite nodes, then press ‘Use Nodes’ tickpox, then Shift+A / Add / Input / Render Layers node


Okay, the three systems are independent of each other - the material nodes are just for objects, the composite nodes are just for render layers and image inputs. Just click the composite node icon to swap over to use the render layer composite nodes and effects. You can turn on ‘use nodes’ at any time during the modeling process, and you can add a viewer node and click ‘backdrop’ to see the results in the active viewer node.

edit: Richard beat me to it. :slight_smile:

Thank you. Helped me a lot.