no visible particles with alt-a on macbook

I can’t see anything happening when I try the the basic tutorial on particles on my macbook, I create a plane, hit the physics button, set norm to one, hit alt-a while the mouse is over the 3-d window, and the mouse arrow turns into a counter but nothing happens, although it appears as if frames are counting. Could this be a macbook issue, or am I doing something wrong keyboard-wise, since the alt button is actually a combo alt/option button? Thanks

cancel that, there is a 3 second delay before they show up!

Well, your first problem is you were dumb enough to buy a mac book, there crappy laptops and there macs. pc’s are way better. Try going into object mode so you can see the particles.

@ yukon
I don’t care for Macs either but insulting people for their personal choices just makes you an ass-hole.