Node Failure To Remove Shadows

Hi All,

I am trying to control the way shadows are rendered in my final.

I have set up some nodes and set my render layers to generate a shadow pass and not to include shadows in the final image.

Blender is failing to separate the shadow pass from the diffuse or image output of the Render Layers node. Does anyone know why?


So shadow separation works for everyone else?

Strange, that works fine for me, everything in on the same render layer?

i think the Shadow pass is a grey-scale mask that says how intense the colors are varied based on where the shadows fall. The diffuse says what the colors of the shadows are.

A shadow is not like, a black color. It is a darker version of the color of the thing in the shadow.

The easiest way to mess with shadows is to change your lights, or disable shadows being generatedin the first place

Yeah, everything is on the same layer.

If you look at the node picture I posted, you will see that Blender DOES separate the shadow into its own pass, but it DOES NOT remove the shadow from the diffuse layer as it is supposed to.

@bupla, can you post a screen shot or BLEND that shows this working?

Yes, that shadow shouldn’t be there. Any change to see the blend file, even a part of the scene?

I hope I understood correctly, here’s the capture. From top to bottom and left to right, the passes are : Image, Color, Diffuse, Specular, Shadow, AO. As you see, the Diffuse pass have no shadows.
My settings are the same than yours in the Render Layers Panel. I can share the blend if necesary.

I wonder what’s up with that?

I am using the Transparent Shadow to get colored shadows. I wonder if there is simply a bug in Blender that does not do the separation for that shadow style?

Tried with transparent shadows and that works well too. Could you post your blend?

Here is my node problem BLEND file.

Thanks for taking a look.


ras_node_shadow_problem.blend (237 KB)

I looked at your blend, and I saw what you mean. In the diffuse pass, there are some kind of “colored shadows”. But I wonder if Blender consider these as shadows or as a result of the transparency, because in the composite image, these colors are mixed up with the shadows.

I also noticed another bug in Blender. If you use TraShadow, shadow only fails. This is very disappointing to me because I like using Shdow Only so I can still get an alpha out of my image.

I think PapaSmurf is right here. You are using transparent shadows and they affect the diffuse coloring of the receiving surface. If the material of the transparent object is pure white, it won’t affect the diffuse of the receiving object.

I tried the shadow only issue and it seems that the color / diffuse information is not there, only the shadow information.

Bug reported. Next time please report your own bugs. This is the only way that most of the bugs will ever be found by the devs. This is especially critical at this time since Blender is at B-Con 3 for the release of v. 2.48 (project freeze specifically to work on bug fixes)…Shadow pass is not a grayscale mask, it is a full RGB (no alpha) pass intended to be multiplied with the diffuse pass in order to recreate a variation or “tint” of the original, whole, BI render (according to the value it is multiplied with back into diffuse). If you want this to be RGBA thern you need to put the tra shadow materials on their own render layer and not wory about shadow exclusion. Blender’s compositor (when excluding and recombining passes) works quite differently from a standard BI render. These passes are designed to enhance or alter a Blender render and can usually NOT be combined to recreate a whole Blender Internal render (this can only be done in the most simplistic of cases). As such, these passes are usually not recombined in the compositor in the same manner that they would have been during a non-composited internal render.


Can you post the link where bugs are supposed to be reported?

As it turns out it’s only transparent shadows that aren’t being excluded from the combined render, the option seems to work just fine for non-transparent shadows. I’m waiting on a reply to find out if that is an expected feature or an oversight/bug in the rendering code.


All I get at the link is a login page. How do you report a bug?

Is this the link:

You have to create an account…annonymous reporting is not allowed. There is account link right under the lost password link.