Non-continuous multi-frame emitter trouble

I have this issue with a particle emitter, and was wondering if anyone could help me out here. I have a particle-emitting plane that moves in space. As it moves, it shoots the particles out, but it only spews them out precisely on every single frame, as opposed to continually. Is there a setting to control this? I’m attaching a few screenshots with the particle settings, in case anyone spots where the trouble is…



I’m bumping this topic up, see if there’s anyone who can help. Thanks!