Non-Linear Animation (NLA) editor

I was looking for the answer to this issue that i have, but i had no luck can you guys help me?

i animate every now and then and i have always use the NLA to combine animation so i can create a more complex ones.
But now that i have the latest version of blender, it seems that the way i use to combine animation don’t work any longer and i can only use one of the animation instead of a combination of several animation and i wanted to know if there was a change of any kind in the newest version that wont allow me to combine animation the way i used to.
This is a link to a tutorial that provide the steps that i used to combine the animation, as you can see you can combine the rotation of the wheel and the position of the wheel, if i do this i can only use one or the other.

Can you guys please assist me with this?

NLA Editor -> N-Panel: The blending type of the upper strip might be set to ‘Replace’. If so, change it to ‘Add’. This way the animations of the two strips are being combined…

Well i try that and it kind of work but the thing is that now the object gets bigger for some reason lol.

I also notice that in some old animation that i have the “blending” option is always on “replace” and it work fine, i can loaded up right now and still works fine, for me this seems a little strange.

Another thing is that i have 2 animation, one that move from point “A” to point “B” and another one that rotate 360 degree.

On the NLA if i use the movement animation first, and below that one i use the rotation animation it only move from “A” to “B” and it does not rotate, but when i use the rotation animation first and then below it i use the movement animation it works, it actually rotate and move from “A” to “B”
This is an example on how it work

This is an example on how it doesnt work

Everything is the same except the order of the NLA Strip

This is the file
Try to switch the nla track as in the picture above to see what i am saying.


Cube_EX.blend (461 KB)

The problem is your movement strip also has rotation and scale keys which overwrite the keys below.
Select the strip (yellow bar), go into edit mode (press Tab -> turns green). In the dopesheet/action editor you can now delete the respective keys (except the translation keys). Go out of edit mode -> now you can swap the two strips without influencing the animation, since each strip has separate key channels.

If for some reason you don’t want to delete those keys, set the top strip blending type to ‘Add’ (make sure you’re doing that in the ‘Active Strip’ section, not in the ‘Animation Data’ section of the N-panel). Now the keys of the top strip are being added up with the keys below.