Noob Question: Stopping dynamic objects from 'bouncing'

(Cognis) #1

Okey, I feel silly, but…

When I make objects Dynamic Actors, they bounce away when they hit something. If both the hitting and the hit object are Dynamic Actors, they bounce away from each other.

I don’t want them to bounce. I want them to just push each other around. How do I accomplish that?

Thanks up front!

0 Likes

(Larryboy) #2

First thing is to make sure their centers are in the center of the object.
Editing panel (F9) /Mesh panel -> ‘Center New’ button
This puts the center back in the middle of the object if you have changed that while editing. If you imagine the physics engine gets an object who’s center of gravity is outside the object its going to have it do some crazy things.
For a more sophisticated solution you can have dynamic properties associated with materials but you will have to read about that.

0 Likes

(Cognis) #3

Uhm… I think you are being faaar too advanced :slight_smile:

Center o’ gravity is fine, and materials seem to be overdoing it. I simply need to turn off whatever makes the Dynamic Actor objects ‘bounce’ each other. If they collide, they must just push each other, not the rubbery bounce that sends them flying everywhere.

0 Likes

(LeftySpinhand) #4

In the materials panel you will find a DYN button. Click it and you will see a new panel that offers tuning for-

Restitution = how much collision force is given back to colliding objects
and
Friction = how much drag results from collision with material

These options tune in values from 0.1 to 1.0.

apply this material to your object(s).

you can enhance this by tuning your Damp function on the objects Actor settings (also 0.1 - 1.0)

0 Likes

(Magnum Opus) #5

Umm…

Your objects could be colliding with too much force. You could try using less force or increasing the mass of your objects.

0 Likes

(Cognis) #6

I tried toggling the DYN variables, but it does not seem to include killing the rubbery nature of Dynamic Actor objects. In fact, Restitution seems to be directly linked, but it starts as 0.0, and raising it worsens the problem, making the objects shoot around whenever touched. 0.0 Restitution seems to be too high; is there some sort of ‘negative Restitution’ available?

As for the force suggestion, can I adjust that somewhere, or is it only controlled by how the objects hit each other? They are pretty soft and tender already. I tried Mass, too, but there were no reactions whatsoever. I think Mass works different in Blender than in my high school physics class, tho.

0 Likes

(LeftySpinhand) #7

I doubt that force is the issue. The bounds of your objects may be bigger than you intend, particularly if you’ve resized it at all since creating it. To make sure this is not the issue:

Select your dynamic object and press Ctrl A to apply scale and rotation to each object. Set the actors bounds size (radius on the actor controls) so that as much of the object as you can get is covered in the radius sphere (pink dotted circle in wire view). A perfect bounds size for a sphere is .01 smaller than its actual size. A perfect bounds size for a cube is .01 smaller than the widest distance between the center of opposite walls

This should help.

Also-
in the GAME menu at the top of blender, enable the Show Physics Visualization button and try running your game again. You’ll find a box a around dynamic objects changing colors and moving around and the object moves. This is intended to help you see where objects are in relation to thier actual bounds and centers in realtime.

Hope this is helping,

0 Likes