Normal Map problem

I have been having this problem for some time now and can’t seem to find a solution to it. My problem is that whenever I try baking the normal from high poly to low poly my normal map always seems to be messed up in some way. The normal seems to have weird lines showing up. I have tried both blender bake and xNormal, both produce roughly the same result. I have attached both the low poly blend file with it. The high poly model is merely a multiresolutioned poly with a smooth modifier applied to it.


crate_1_box_low2.blend (477 KB)

Umm. that map looks correct. In what way are you saying it Isn’t?

Well the normal map itself seems fine, but when I go to blender I get some weird results

[ATTACH=CONFIG]195793[/ATTACH]Here is the results Im getting when I apply the normal map

You forgot to pack the normal image in the .blend :wink:

The blend file now has the image packed into it. Im still getting the weird lines.


crate_1_box_low2.blend (583 KB)

Also the normal map is meant to give the object a sort of a smooth look on the corners and edges

The new blend file with the normal map image packed in it is attatched


crate_1_box_low2.blend (477 KB)

Ok, you still have not included normalmap, but that really does not matter - we could bake one easily. What is not included is low resolution object to put normalmap on (or is this the low res one?).

On texture panel you have not set Image Sampling - Normalmap checkbox. That needs to be done too.

Hello! I have the same problem :confused:
I’ve intended to create a lo-poly cube with smooth edges.
I’ve baked map, applied it to lo-poly cube, but result… looks strange :slight_smile:
Where is my mistake? :slight_smile:

Cannot attach archive:( Here is the link (~300kb):

Your normal map looks wrong, reason for that most probably is that you’ve baked your normal map while your low poly object’s all normals were set to solid/sharp.

For such a object which does not have any sharp corners ALWAYS set your lowpoly model’s shading to smooth.

This is how your normal map should look.

As Eppo said.

On texture panel you have not set Image Sampling - Normalmap checkbox. That needs to be done too.

Make sure you always have that checked when texture is a normal map.

Here is updated version of your blend file. Layer one is correctly baked normal map, layer 2 is your normal map and layer 3 is the highpoly model.

ok thank you so much, I knew I was going wrong somewhere. Thanks to all who helped

I guess this thread is now solved