Normal Map Won't Show Up and Bump Map Artifacts.

Guys,

I am trying to bake my high res bar to low res bar. Shown here is the high res bar.


I have managed to bake AO to my low res bar. Everything is fine. However when I baked normal, the normal map is pixelated and the holes from the high res bar are missing. See pic below



When I applied AO map, the above Normal map and AO map as Bump map and rendered, This what I get


There is no normal or bump. And there are some white dot artifacts. What have I done wrong?

Below is the blend file for your reference. (High res is in another layer)
http://pasteall.org/blend/13288

I have checked Normal map and select tangent in the Image sampling. Mapping coordinate to UV. I also set normal influence to 1 in Geometry. But the outcome is still the same. Any solutions?

I happen to have had issues with this lately; for me, I was using a normal map of a different dimension than the texture (a 512x256 texture with a 512x512 normal map, each using a different UV map). Only the bottom half of the normal map (ie. the part outside the dimensions of the texture) would show on the object when mapped to.

Also the bump pattern would haphazardly show up-side-down or suddenly not at all when switching the options around at the bottom of the texture properties panel (“Method” -> “Best Quality/Low Quality”, “Space” -> “Object Space/Texture Space”). Even changing one of these to another option, then switching it back to the way it was, has made the normal map turn off when it was on or vice-versa in the editor.

Try fiddling with these to see if it suddenly wakes up and uses it. In the editor it seems to be random, and looks like a bug that ought to be submitted to the tracker. It did however seem to show it correctly when running the BGE. What happens when you hit “P”, or render it?

blitzen,

Tried your method but the outcome is still the when rendered. No bump or normal. This is driving me nuts…

Can you attach blend?

Edit: found it after I read your whole post :slight_smile:

First your textures in material are incorrectly set.

Your normal map uses generated coordinates for mapping, should use uv (you know this, right?)
You need to enable “normal map” under image sampling so blender knows this texture is a normal map.
You need to disable color and enable normal from the influence panel.

You can’t use AO map for the bump map, it will not just look right. Also, if you want to use a texture as a bump map you need to do these two things for the texture. From the influence panel enable normal, and for bump mapping space choose texture space.

And if that texture will only have that one object then I recommend to make that texture 128x1024, there is alot of wasted texture space if you want to leave it 1024x1024

Your highpoly also needs some love but that is another story, if you want to hear it then just ask me in this thread and I will clarify a bit.

Etana,

I have checked Normal map and select tangent in the Image sampling. Mapping coordinate to UV. I also set normal influence to 1 in Geometry. There is bump map but it is not strong enough.

If AO is not good for bump mapping, what would you suggest?

The main issue I have is baking the Normal map. The baked normal map is missing the holes and pixelated. Only the bevel part of the bar is working. Any suggestion?

If AO is not good for bump mapping, what would you suggest?

Normal map, when baked properly

The main issue I have is baking the Normal map. The baked normal map is missing the holes and pixelated. Only the bevel part of the bar is working. Any suggestion?

Your high poly model needs alot of work, your current topology will never look good with sub division and you need to use subdivision on our high poly mesh.

I have some spare time now so I model you a example of what how your highpoly mesh topology should look. I will edit this post as soon as I finish it.

Edit:

http://www.pasteall.org/blend/13323
Here is the new blend, it includes that same high poly bar with better topology and subsurf modifier added, check it out and try to make all your other high poly models same.

Also I added two low poly meshes for that high poly shape and baked normals from the high poly.

And you can see how to control the strength of those “holes” in the normal map by looking at how different the first “holes” look like in the high poly mesh,