NOT AGAIN: Cannot Texture Paint In 3D Viewport

Ok, this is probably many times people ask the same question. But I cannot seem to paint in 3D view anymore. Since 2.6x? I can’t remember, it used to work no problem.

Multitexture is not showing any texture. GLSL is ok. I can paint on the flat UV window no problem, but not on the 3D view. Is this a bug?

I sounded like a real noob.

:spin:

  • Jimmy
1 Like

I think it’s really a bug. Many people will encounter the same thing, I bet.

The problem: UV Painting works in UV/Image Editor, not in 3D View. On 3D view, it is showing the circle, cursor moving but nothing happens.

I really expect it to work right away when I jump to UV Editing, and switch to Texture Paint mode. But it does not. I found the solution, after 1+ hour of trying, do this in order:

  1. Go to your 3D view panel, hit TAB.
  2. Now with your 3D view in Edit Mode, your UV editing panel (on the left side) should show the UV lines.
  3. Select the image texture that you like to Texture Paint in the UV Editing panel.
  4. Hit TAB again in 3D view. Now painting in 3D view is working!! Why? No idea.

Is this happening to anyone?

Ok, now I completely understand it. It may not be a bug, but something that Blender user must get it right. A little not so intuitive.

Step-by-step above indeed needs to be done exactly:

  1. First problem: Doing that step-by-step (going to Edit mode, selecting texture in UV Editor, back to Object Mode) ensures that Blender knows what texture to work on. If you do this correctly, texture will show up on Multitexture setting.
  2. Second problem: Sometimes user also accidentally link Texture in the wrong slot, accidentally painting texture over using the same texture they are working on. Get rid of that “Texture”.
  3. Third problem: When using Stencil, must make sure “RGB to Intensity” is checked. “Stencil” option is checked, and Color OFF.
  4. Fourth problem: Sometimes GLSL preview does not load properly, in such case use the Refresh button on the Texture tab. Do this for every layer of texture you have.
2 Likes

Thanks for posting this solution . I spent weeks, possibly months trying to get this 3d paint thing to work, was never successful and when it did work sometimes, i couldn’t understand why it worked.
Thanks a lot man!

Thanks so much, works fiiine now

Wish I could understand your instructions, seems they work. I need visuals for my learning, in order to learn this program. Do you know of a video that shows your instructions? Thanks if you do…

In Blender 2.80, the Material and 3D Texturing is simpler, you basically need to assign a Texture into the Diffuse Color first at least. Try the N or T panel while you are Texture Painting and create Diffuse texture and paint away. I can make a video.

Here is a quick casual video on setting up Material and Blender 2.80:

Thank you so much.

mine still isnt working, i even make a new texture, make a new uv, all that. and it refuses to paint

I just had this problem and couldn’t figure it out until I accidentally zoomed in too far and suddenly started painting on the inside of the mesh. Turns out my normals somehow got reversed and you can’t paint on the back faces. So if anyone else has this issue, try flipping your normals.

1 Like

Just repeating this, as it’s a hell of a ‘gotcha’.

3 Likes

so according to this other post:

the problem for me was the default texture the brush used which was a black square. since the alpha color was black it meant that the brush was pretty much invisibly painting the color. aka painting nothing. I deleted it and blender reverted to the default brush shape which was a completely opaque circle. I could finally paint on my little cupcake model!!!

This was my problem too. Thank you. For anyone curious, you can tell if your normals are flipped by going to Overlays and clicking “face orientation.” Anything you see that’s red and facing out is flipped. You can flip them by pressing Shift+N and then turning off the face orientation overlay.

able to paint in solid mode but not in material mode. can any body help

Try ctrl+shift clicking (with node wrangler obv) the image you are trying to paint

Well for me I checked recalculated the normals and it worked out fine, if you wanna check if the normals are facing inwards go on overlays and click on face orientation, if it’s red that means the faces normals are inwards

That was it …
Damn, it’s happened so many times, “why does my normal map look so weird??” " Why’s my texture so dark on this model??" “What the *** is happening ???”
9 out of 10, it’s because of those flipping flipped face normals …

Anyway thank you all for the tip.

And for all of you out there : always suspect face orientation