Not enough bounces in Cycles?

Hi,

I am testing a product, and the product looks good: plausible albedo values for grass. So I think the creator did his job well, but the point is that the shadows are to dark in Cycles. Or in other words, I think, 32 bounces is still not enough.

Here I did a test. This is the original render with 32 bounces:

If you look close at the grass blades, you will see that that albedo colors match quite good with the HDRI.
But the shadows (between the grass blades) are very dark, nearly black. And that doesn’t look good.

Now I replaced the dark shadows with a color (in post) that matches the ground. This, to see the impact of the too dark shadows:

Now you see what an impact those dark shadows have (look from a distance).
If I compare that with the shadows in the HDRI, that is the thing that doesn’t match.

Any idea how to improve such a render?

Maybe its not the bounces but the way Cycles works, I heard once someone saying “In cycles, I can’t get enough light into the scene”?

Is anything preventing you from simply trying more bounces?

I’ll try, it with 128 bounces, but I don’t expect much difference. Will give an update.

You may also try more samples, depending on the amount you are currently using.
Also, the material/shader itself may be the cause for this sort of effect. What kind of shader does it use?
What kind of color management are you using?

From 32 bounces to 128 bounces there is no visible difference. (I zoomed in on the shadows).
I thought about the samples too: indeed the first few samples show some very dark pixels, so I am using 3000 samples.

The material is using transparent, translucent and principled bsdf. Maybe I have to find the answer in the translucent part, but I suppose the creator found out the best mix for that.

From the side-view the assets look awesome, but if you look from the top you notice that shadows are quite dark.

The materials can definitely cause this kind of effect. But the color management can too! Maybe check that one as well.

1 Like

Try setting the preset to full global illumination.
No idea if it will look better but it has been my go to preset for rendering realistic glass materials.

2 Likes

I’m not sure if you are approaching the issue correctly. To make the comparison that you do, the material of your vegetation should also behave in a similar way that the real vegetation of the photo does.
Have you tried modifying the material vegetation by making it more translucent or using SSS?
You could also try Ambient Occlusion values in World tab (In official Blender releases, not in Cycles-X).

2 Likes

Agreed, this looks like a material issue rather than a rendering issue. 32 bounces should be way more than enough here. If the grass has no thickness, increase translucency (not transmission on the principled shader and don’t mix in more than 0.5). If it does have thickness, use SSS. Hope that helps!

1 Like

There is a translucency setting in the node-group made by the creator (increase/decrease).
While it makes the grass appear lighter or darker (depends on relation to lightsource ofcourse),
the shadows (on the ground) stay the same.

Here the screenshots:


I zoomed in on the shadows (ground) and there is barely any difference.
I have the same impression when I render trees: In real life, it looks like there is much more light bouncing around if you stand under a tree (is that called ambient light, or global illumination?). In renders, it goes nearly black too easily.

Update: Now I suddenly remember I did something in the past with transparency setting (strangely enough), which showed big difference. I’ll experiment.

1 Like

Posted on Twitter the same question. Here is the thread if you want to see it:

Answer from Troy:
Cycles isn’t that smart.
If there is energy attenuation, it is purely the BxDF.
Which of course could be wrong. What you are seeing is all part of the image formation likely.

I just went outside in our front garden where there is a cylindric hole in the ground.
There is overcasting sky, late in the afternoon.
The cylindric whole is around30 cm deep, and a diameter of 15 cm.
I was able to see everything in the cylinder, but I am pretty sure it would be nearly black in Cycles even with full global illumination.

You have to account for the difference in the way Cycles renders and displays dynamic range, compared to your eye.

You’d probably have a similar issue if you tried to photograph the cylinder.

Have you tried looking at some of the colour management settings, particularly filmic?

1 Like

Yes, I understood from Troy that stimulus is not a picture. (Can’t find the message back on my Twitter, so I cannot precisely quote the words at the moment). While I understand that stimulus and an image are not comparable, I still want another distribution of contrast in the final render.

The picture (straight from my phone) of the hole looks like this:

If I put the gamma down (in Affinity photo to .5), then it looks approximately what I saw, I think:


Yes, that is pretty much how I experience it. But I am sure we cannot get this out of Blender (and probably any other render engine, I guess).

What exactly is going on (bounces/view transform, etc.), I can’t explain.
The fact is that in renders, I usually want another distribution of contrast. Here the first graph shows how I think it is, and maybe I want more like what the second graph shows:


Decreasing contrast is not what I am looking for. So what I am looking for is a bit less contrast in the low and a bit more in the high. I wish there were a slider that let me balance the curve.

Try “Filmic” under the “view transform” setting on the colour management section of the render panel. That will give you more dynamic range than “Standard”.

You can then tweak the “look”, gamma value and exposure to give you the actual dynamic range you want to display.

Yes, I always use Filmic.
I never played that much with gamma, because I’ve seen a message in the past that we shouldn’t touch this, but lately I changed my mind and play with it frequently.

Yes, I know the exposure and looks. I also used the pivoted contrast node I got from Troy, which lets you adjust the look step-less (not presets, but a slider). And you can set the pivot point around where values have to drive away from each other (usually mid grey, value 0.18). But still, that doesn’t let me change the fall-off of the amount of contrast towards lower values.