Numpad blues (int keymap)

Hello everyone,

I’m quite new to Blender interface and things are going quite smoothly, but one thing that irritates me is that Blender doesn’t accept comma from numpad as decimal point. I’m using finnish keyboard mapping as default (in Windows 7) and it works with Blender 99% ok, but this is just buggin’ me. Well I can type period from another location from the keyboard but it’s just… silly.

I’m not using any other mappings or registry hacks (or SharpKeys) to solve this. I tried SharpKeys to remap comma as period and then Zoom (numpad) in Blender stopped working…

So if anybody knows how to make Blender understand that comma, when typed from numpad is same as period (and therefore accepted as decimal point) please enlighten me (and maybe someone else too)