.OBJ export broken in 2.45?

Is the Wavefront .OBJ file exporter broken in 2.45? Any model I try to export ends up having it’s color turned to solid black and its normals flipped outside-in. Here are the settings I’m using:


The model I’m exporting is a single low-poly mesh, white material color with UV’s and texture. I’ve verified that the normals are correct as is mesh color and everything else. If I export to .FBX it comes out fine, only the .OBJ export isn’t working correctly.

What are you using to view the models? - it sounds like you might have negative scale on your object.

I was having the same issue. I’m using Max to view models, though I don’t have the black problem. I wish Max had a “Recalculate Normals” command.

Jeesh, it was my mistake all along. I always forget to “apply scale/rotation” before exporting and I did it again with this model. I did a Ctrl-A and now it works just fine. Thanks for your help Cambo and sorry for the inconvenience.

you shouldn’t have to apply size/rot. High quality normals and no negative scales should do the trick.

I tried setting High quality normals, but that didn’t fix it. How can I tell if there are any negative scales in my mesh? It looked OK in object and edit mode (I didn’t create this particular model BTW).

look at the transform properties (nkey) in object mode and see the scale value - also - the parent having a negative scale could do this too.

Thanks again Cambo!

Max does have a “Recalculate Normals” command, it’s called “Unify Normals” and located at the bottom of the Edit Mesh modifier.