Object added via Empty doesn't appear

Im using experimental UPBGE 0.3.0 Eevee. No Python, only Sensors and Actuators.
I just followed a vidoe on Youtube, where it seems so easy:

  • just add a Sphere in one layer
  • then add an Empty near the Cube in the main layer (Coin-like thing)
  • Finally link the Empty with the Sphere by adding Sensor “Always” + Actuator “Edit Object” and add the Sphere name into the Object-field
  • (link these two and the AND-Controller is added automatically)
    (NO OTHER CHANGES MADE, no visibility-stuff, nothing!)

Now I have two problems:

  1. It seems like the AddObject via Empty doesn’t work: I can see the Empty-Object in Edit Mode and used SHIFT+D to copy it once (both have different positions than the Sphere itself). But when starting the game with P there is NOTHING. (checked the positioning already)
  2. a) If I activate the visibility of the second layer with the Sphere, I can see the Sphere at its position, but NOT at the desired location which should be activated by the Empty-Actuators.
    b) If I deactivate the visibility of the second layer, I don’t see the Sphere not even in its original position (which would be logical to me)
    c) I also tried to put the Sphere in the main layer - this doesn’T chage anything. The Empty-Actuator doesn’t work.

I’m really desperate, because there are so many stupid changes in these new Blender-Versions (I know it’s not your fault!) - especially this layer-stuff makes me go crazy… it was so easy to handle with this button-system before…

Please help me out.

upbge 0.3.0 got no layers, unless experimental UPBGE 0.3.0 Eevee got them.

what you should do is:

  • create a sphere in the outliner (objects tree) click the eye icon to hide it.
  • create an empty and put sensor → and → editobject/addobject and select the sphere


incase with layers, then it should be:

  • sphere in other layer
  • empty in main layer, with the same bricks as screenshot bricks on the empty

The desired object to be spawned must be hidden before being added. Otherwise spawning will not work.
If you don’t already know how to hide an object there is 2 easy ways:

  • Select your object and than click the H hotkey to hide your object (ALT + H to unhide it)
  • Or toggle the Eye icon in the Outliner Editor for your object to hide/unhide it

Else if it doesn’t work for you feel free to drop a blend and I or another can take a look at your blend and hopefully point you in the right direction.

UPBGE 0.3 now have working scene Collections instead of scene layers. Have had them for months to be honest.

indeed but it ain’t layers, it’s all crap in main layer, you need to hide some things and others not, it’s a crap system to be honest.

Hi everyone.

THANK YOU soooo much for all your wonderful help!
The guy in the video used an older version of Blender with GE and Layers. So he just deactivated the layer and it worked. So I thought that these stupid Collections would be the new Layers and deactivated the entire second Collection with the Sphere.

:+1: Deactivating the Sphere itself worked perfectly! :+1:

OMG! I thought it would be easy… but because of the many changes in the newer versions I need to find out about EVERY single step! It’s horrible!

But thanks a lot! Wish I could share one of my self-made Pizzas with you! :slight_smile:
Keep up your good work!