Object adding problem

I have one object set to emit another that is in a different layer. The object emits but it emits too far forward on the y and wont make contact with my floor object unless I scale the floor 9 times on the y axis. I have already applied scale and location and rotation. Please help

.blend? if it is to big there is always pasteall.org/blend

up to 30 megs I believe

sorry cant give blend. not my project alone


1.- Are you using a empty to emit the item?
2.-Is it parented to what you want to emit it from? (then you can move/re-center where ever)
3.are your emission settings local or global?
4.What is your floor mesh physics settings ?
5.what is your physics frame rate

a cube with sensor physics is emitting. the object is not parented. my emission settings are global but there is no initial velocity, it’s gravity based. the floor is just static but only 2 blender units thick on the y axis. when I stretch it to nine it catches it. untouched physics framerate 60 with a max step of 5 and max logic of 5

the object that is emitted? is it only on on collision layer? (this is good for cutting the physics interactions)

ok, so physics of ground? trianglemesh?

physics of emitted body?

problem as i see it is when i play it and drop the object above the ground i see it go right in front of it. collides fine when the ground is scaled 9 times on the y axis. but this doesnt work for the art side of the game.

The emitted object is rigid body with one collision layer

ok, so what is the floor physics?
What is the collision bound type?

if you spawn it “in” the object I am not sure it will collide with a surface, you need to have it be just above it, have you checked with your item lifted higher?


It is really hard to guess what you have in front of you.

A good way to present your problem is to create a demo file. Try to reproduce the problem there. No textures, no complex meshes, no unnecessary objects. Just the objects involved. This keeps the size small and your art protected. Finally it does not force the reader to fight through irrelevant data.

The best argument is it is very likely you identify the problem yourself while preparing this file.

BTW. have a look at scaling


Here it is. You get the idea. It may be something really simple that I’m overlooking but I cant find it.

Start on Menu scene-click the middle button-click the top right block and it will spawn a triangle- drop the triangle over one of the bricks and it goes right in front, can also hit right mouse button to cancel selection.

Well, first off, where does the camera move to where these things are?

why not just have them on another layer, and then have clicking the button delete the button and spawn the stuff??

I can’t look at the spawning system, or planes, unless you have the scene set up so it is possible to find

I found your problem. It’s with your custom cursor script. It gives your cube your using for you cursor a position really close to the camera. If you turn physics visualization on and then put the camera in perspective mode you can see this happening. My suggestion would be to change:

own.localPosition = mPosi.raySource

to this:

own.localPosition[0] = mPosi.raySource[0]
own.localPosition[1] = mPosi.raySource[1]

That way you don’t have to worry about it jumping to the camera.

Your script is also being effected by the orientation of the camera, so you might want to expand on it a bit more. For example if you use the fix above(doesn’t matter if you use world or local scale) you can either have your cursor act as expected, or you can have the movement of the triangular prism work as you want it to, depending on the axis you use while setting the position of the cursor.

THANKS! that kinda worked. solved the landing problem but now i cant move on the z axis

Nevermind I got it. My cursor overlay and levels were at different views. I lined them up and its perfect thank you sooooooo much. dont know scripting so I was really hating wasting time while i could be working thank you!