Object does not cast shadows (nor on itself) but receives shadows?

It seems that no matter what I manage to do, I can’t get this plane to render correctly.

I am trying to render an object on a plane (the plane acts as a floor per say) and I want the plane to remain white (blend in with the background). The only time I want the plane to deviate from white is when it is receiving a shadow from an entirely different object.

Shadeless does the trick (keeping the plane white) except for the fact that the plane wont receive shadows from other objects. Is there a way to do this?

Edit: I should also add that it works properly if I use the CookTorr method with a Specularity of 2.00 and a hardness of 1 but only with the blender internal renderer. I would like this to work with YafRay.

There’s an option to make objects that are invisible except where shadows are cast apon them. You could use this, and either make the background white or have a second, Shadeless plane undernieth the first one.

Any idea where this option is? I can’t seem to find it.

In f5 reduce your planeś Alpha value to 0.38. Alpha slide button located under RGB slide buttons.

Other option is to press shadow only button in your lampś settings, but then you need another non shadow lamp to light scene. Option one is still the easiest. :slight_smile:

Does anyone have any other ideas or does anyone know where that “transparent except if object casts shadow on it” option is?

I tried your alpha value fix ozo but it isn’t resulting in the effect that I want.

F5 Editing, Materials buton, Shaders panel, third button next the Hardness slider OnlySh. Looks really cool; just this shadow floating out there.

Note: alpha 0 transparent objects cannot show a shadow, because the light does not bounce off of it. an Alpha of .5 or as Ozo suggested will allow you to see objects behind the plane, altho the shadow wont be quite as dark.

hmm so u want the plane the same color as the world? y not make the world the same color as the plane…hmm