Object doesn't rotate


I’ve modeled a pyramid and want this pyramid to spin around its own z-axis. I found a good tutorial, but the pyramid doesn’t spin. :frowning:

Here’s the .blend file.

pyramid.blend (1.26 MB)

Plus, when I render a still of the pyramid, it has a weird shape, such as:

Can anybody help me there?



The rotation is keyframed and has no change in rotation value. It’s also fully reflective surface, and reflects whatever is around. Higher roughness for the glossy shader reveal the surfaces better

Use keyframe animation. You need to choose some property you want to animate and then keyframe it at some frame and then keyframe it changed at some other frame so the property gets interpolated in between and you can choose how the interpolation is done in the graph editor by the way, but leave learning that stuff for later. For example keyframe z rotation when the frame is 0 by pressing i while hovering your mouse over z rotation value somewhere on the interface(for example in the n panel under Transform when the object is selected), then you need to change the current frame on the timeline, like for example to 200 and change the z rotation value by adding something like 360 to it and keying it with i while hovering your mouse over it again. That’s it - when you are at frame 0 and hit play on the timeline or alt+a, the object will spin.

By far the easiest and most reliable way to make an object spin (and never flip around) is to add a single driver to the rotation axis with an Expression like this:

(frame - n) * x

Where n is the first frame of your animation - normally 1 and x is a spin factor. Drivers work in Radians, so to get degrees you multiply your x by pi and divide by 180 e.g.:

(frame - 1) * (5 * pi / 180)

Will spin the object 5 degrees every frame of the animation. You should check “Autorun Python Scripts” in User Prefs => File tab to let expression drivers work. Just put a minus sign somewhere to make it rotate the other way, like this:

(frame - 1) * (-5 * pi / 180)

Cheers, Clock.


Here’s a picture:

Thanks a lot for all the answers. I made the animation anew, but for some reason in the 2nd keyframe (last frame) doesn’t accept the value ‘360°’. When I enter this value and play the animation, the value is ‘0’ again. The only way to make the pyramid rotate is when I edit the F-Curve :(, but the the pyramid rotates around the y-axis. And I didn’t find “Autorun Python Scripts” in User Prefs. In the tutorial, it looks so easy that I am asking myself, what mistake I’m making.

Here are the settings for ‘Transform > Rotation’:

The ‘z’ value remains ‘0’, no matter, what I try.

P. S.: Finally, it works! :eyebrowlift2: After watching the tutorial once more, I changed the ‘Z’ value to ‘350’ before making a second key frame. The only problem now is that the pyramid is slightly off-center, but I’m confident that I will find a way to fix this. Thanks again to all who responded.

Meanwhile I was able to render an animation, but there’s a strange black box in some of the frames which is not present in the scene. For some reason I wasn’t able to upload the animated GIF, but here’s one of the frames with this mysterious object:

I rendered the frames as 8-bit PNG’s RGBA. I then tried to render the animation without alpha channel, but to no avail. The box is still present in some of the frames.


Apparently I need to learn the stuff first… see the expert’s view in the post below.

So I shall stop helping here until I have learnt something.

Clockmender, this is simply incorrect. Learn the stuff before teaching it. Right now you are just confusing others.

You can keyframe any rotation values. With Euler rotations it is possible to get into trouble because of the way Euler rotations work so it’s not as simple as it might seem at first in some cases and you have to know what is going on to get results you are after, however keyframe animation does not have anything to do with it. Spinning an object around one axis will
present no problems. It is very simple to try it for yourself - just a few clicks:

I have more than 30 user files where this method has not worked reliably and not one where drivers have not worked - learn some respect before you shout your mouth off.

The information you provided was misleading. I just pointed it out because it was not true and it was confusing. If you have problems with your projects, you are welcome to share them so somebody here can see what’s wrong in there. I honestly believe you should learn the functionality before teaching it to others because it may make their learning process more difficult otherwise. It’s a pity you seem to be more interested to take offense than to see your mistake and correct it. It reminds me of this: https://www.youtube.com/watch?v=F-mju_gW3c8