Object in viewport is an indistinct grey after rendering


my project turn to this after rendering it

You need a light in your scene- press Shift A, go the light submenu, and pick one

i already have one

Increase the brightness or move it closer

nothing changed

cycle
i have this problem only in eevee and cycle render engine , in the cycle it shows like this


in workbench it look like this , and that’s what i want but in eevee render engine

Share your node tree for the material, and seriously, turn the power of your light up. Start with 200

That looks like you have no HDRI connected, but have Scene World checked and Scene Lights unchecked.

Workbench doesn’t care about HDRIs so you see something.

2 Likes

Sorry, I should have added how to fix that – unchecking Scene World should work immediately, because you will get light from the default background colour.

If you also check Scene Lights, your point light will work too.

1 Like

this is my second acount ,blender artist says that i reached the maximum reply for a new user , however thank you so much for your help i spend last night searching for this in tutorials but i didn’t found anything helpful

1 Like

This sort of thing is really difficult to solve for a beginner; Blender has so many options that one can accidentally turn on or off with a random key press. Glad we could help!

1 Like

thank you men :heart:

1 Like