Object rendering as black

I’ve started modeling a spaceship, just for fun, but it won’t render. When I render, all I can see is a very pretty starfield, and the space where the object should be is black. As if it has a black, shadeless material. But it doesn’t. I tried adding a new camera and rendering that instead, but no change.

  • Select all the verts and press CTR-N to recalculate normals

  • Do you have a ight in the scene?

  • Add another object and see if it renders.

Otherwise could be a number of things, posting the blend file is probably the fastest way to diagnose the problem.


Normals are fine. I have two spots in the scene, both pointed at the ship, energies at 1 each, colours on, etc. I added another cube, and it didn’t render either!
Here’s the .blend… (don’t laugh at my design ;)): http://www.savefile.com/files/120219
Is there an easier wya to atach blends than finding a host?

I’ll take a look and see, (you’re URL was mangled)

File Url

My modelling skills are non-existent, so I won’t be laughing at anybody :slight_smile:


The problem was with the combination of your lights being positioned beyond the shadow clip end range and the Shadow setting in the render panel being turned on.

Either Turn off Shadows, or increase the Shadow Clipend value in the lighting panel / Shadow and Spot, or move the Lights within the Clipend range.


The clipping distance on your spots is too short so their light is not reaching the model. Select a lamp, press F5, set Clip End to at least 100. The line in the middle of the spotlight’s cone indicates the clipping

Edit: er, what Mstram said. I’m half asleep–what’s the interaction between the Shadow setting and clipping?

I was hoping you would tell me :slight_smile:

AFAI can see, the Shadow clipend limits are only active if the Shadow button in the Render panel is activated. The lighting and shading panel though, is an area that I’m not very familiar with.

The other weird thing I noticed in this file was that my first guess was that the camera clipping miight have been too small, when I try to increase it Blender hangs (or at least stays busy longer than my patience allows ~1 minute or so)

… It seems to be related to the “Stars” setting being on in the World panel, possibly the Mindist being 0 ?? … Even when I increased it to 1.0, though Blender is still hanging when I increase the Camera clipping.


Thanks, guys, that worked :slight_smile:

Blender doesn’t seem to be playing up with camera clipping for me…