Object transparent during modeling?

The object I’m working on, occludes the background image -which serves as a guide, so I need to make the object transparent during modeling. I can’t find such settings, how can this be done?

press h to hide an object, and alt-h to unhide (You can also use wireframe ‘z’ key)

Edit: Another way is to set viewport shading to ‘Bounding Box’ mode.

So you cannot see through objects while modeling? I think this is very limiting. BTW why does the object (icosphere) disappear in object mode when I enter wireframe shading mode?

You mean setting an alfa value to the model while modelling? As far as I know it is not possible at this time, however wireframe is the traditional method of seeing through a model and can easily be toggled in less than one second. It is also the standard method most often used to see through a model with many industrial standard modelling software, and sub standards. You can choose to select verts, faces, or edges and hide them with h key just as you would in object mode.

As for your icosphere, it may be that you are zoomed in too much and are looking through a face. Or your model color could be the same as your background/image. Besides that I don’t know.

Thanks for the response, but I just found a way to do it:

  1. In Object Mode, at Object panel, Display settings, enable “Transparency”.
  2. In Material panel, new slot, new material, enable “Transparency” settings, lower Alpha value, DONE! :slight_smile:

EDIT: This works in Blender shader mode.

About the icosphrere, I don’t know why it disappears in wireframe mode (probably a BUG). If I apply the Remesh modifier it becomes visible but it introduces artifacts and changes the mesh -not a solution.

1 Like

ooo, I never thought of using that to see alfa in viewport before. That must have changed in 2.62, I am using 2.61 and I don’t have “enable transparency”. Although if shading is set to GLSL with “Textured Solid” on, then that works. Its kind of a work around though, since you have to change the materials that are being used for an object, it would be inefficient to use that method with multiple models. But I honestly don’t see allot benefit, vertices and edges are so small you would require a high poly count to really need to use alfa. But that could just be a matter of opinion, I have worked with wireframe for so many years now :stuck_out_tongue:

Edit: It would be especially painful if you did that with a model that has many materials on it.

Well, I’m trying to do some complicated precision booleans between curvy objects -I just care about modeling -not assigning materials for render (I’m not using Blender to render).
But unfortunately it doesn’t work perfectly. It introduces strong artifacts and other problems.

Have you tried enabling Wire (from the dropdown menu, not the checkbox) under Object tab->Display? Works great with Booleans for me.
I also prefer N-panel->Display->All Edges, so flat surfaces aren’t “cleaned”

I select the “Wire” checkbox from the Display dropdown -not the “Maximum Draw Type” menu which defaults to “Textured”.

I settled on the following settings (which work well enough) after I experimented a little. See a quick example (not a representative one, I couldn’t post my work) in animated gif which also shows the necessary settings -this is what I get:

EDIT: “All Edges” was a good tip, thanks!