Object with basic hair crashes with basic animation v2.8, v2.81


I’m certain I’m “doing things wrong” (in many ways) but been bashing my head against this particular problem, and can’t see a solution.

I have a scene depicting some viruses as boids floating in air. Lots. These are based on two, but I thought to add a third type. I would of course thin out the herd a bit.

So I settled on a hairy pill virus type, and made it in its own Blender instance. WHen I tried to append it into my virus cloud thing, I got an instant crash (Blender just vanishes) as soon as I press play. Even on restart of Blender, without the new virus, the old version crashes now when animation played. At one point I found it was only at the end/loop to beginning. At another it was whenever play was pressed. The file was corrupted?

Thinking I was misunderstanding the Append function, I re-modeled the pill virus with hair in the saved as version. Everything was fine until I added hair. Without hair, I could animate the pill virus (to move from point A to B, or rotate) But when I add hair, even without hair dynamics, the act of trying to play the animation crashes Blender immediately.

I’m using Blender 2.81a, on a Windows 7 Pro with Sandy Bridge 8 core CPU, 32GB RAM, ASUS ROG 1080ti. I’m using Eevee because I can’t stand Cycles (probably a basic misunderstanding on my part)

As for more efficient ways of accomplishing this scene, that’s likely a multiple topic for other threads.

Thanks for any input! (I’ll figure out a way to post the file somewhere… it’s too big for here)

OK, here’s the file! https://www.dropbox.com/s/ptb3jja3ikev5g8/Virus%202b%202%20tone%20multiples%20aerialv3.blend?dl=0

Looks like a bug to me, I get a seg fault when I try to play your file…

Writing: /tmp/Virus 2b 2 tone multiples aerialv3.crash.txt
Segmentation fault

I use Linux Mint 19 so it doesn’t look like a OS issue. I would put in a bug report for it.


1 Like

Thank you Grimm (Jason). I’m way too new to know if the problems I run into are simply noobiness or a combination of noobiness and bug, or whatever.

FWIW, I did do a render successfully of the same scene, but without additional “viruses” … I added hair to my existing model for my “2nd” virus, and while that did crash a few times, I did also manage a render.

I’ll report it as a bug though, just in case. It might be hair particles in combination with boids …?

I understand, but a Segmentation fault is caused by the application trying to use memory that is outside of what the OS gave permission to use. It is almost always a bug in the application. :slight_smile:



Thank you for taking the time to shed some light. Really, it’s very much appreciated.

1 Like

Reported as bug. However, not sure it qualifies, despite it recurring regardless of Blender version. I tried to reproduce it, but was unable to see any problems. Could be my inefficient way of doing things just asks Blender to ask the computer for resources it’s not allowed to use?

I think the devs would still be very interested in this issue, especially your test file that crashed on my system too. It could be an uncommon corner case that they would need to know about.


Well they apparently are taking it as a bug. My report was not perfect, but I think they got the gist, and apparently agree. The funny thing is that I’m basically doing the same thing that caused it, but unable to replicate the bug. So it’s some particular combination of details.

1 Like