objects aren't rendered in cycles (bug ?)

I’m working again on a new product design visualization, for a design concept presentation.
Now i’m having a problem, some parts (whole meshes) are not shown when i render.
And this started after i did some hiding and unhiding, i did the hiding by pressing ctrl H and alt H.
Restarting blender or reloading doesnt bring it back.
Its only in the cycles render screen that objects start missing

In the outliner hierarchy pane, the objects are shown as to be rendered.
I’m using the official blender 2.71 version

I also notice that pressing alt H more times then i actually used H to hide increasingly eats memmory (strange).

Sadly i cannt include the blend file here, as the real product hasnt been released yet.
Any ideas of what could have gone wrong here, and how i might recover from it.
To me it seams some unbalance in setting hiding/unhide attribute of scene objects.

Note also i didnt do anything with scenes to disable objects, all objects are in one visible screen layer
It happened after i did some hide and unhide. Assigned material does render on other object meshes, its not even such a complex material.

Check the object panel, under ray visibility, and make sure camera is checked.

can you make a sample file with only one obj so we can check it !

happy bl

If you pressed ctrl-h, it will toggle restrict render… as in not to render that object at all. to bring it back is ctrl alt h

otherwise you could run this python script to make evrything visible & everything renderable

import bpy

for a in bpy.data.objects:
    a.hide = False
    a.hide_render = False
    a.hide_select = False

H can also be used in edit mode
anyway to test that too !


Hmm… might be a bug… I was just trying it in BI, and it’s doing the same thing. Seems to me I remember that “hiding” only hid from view in the editing viewport, not the actual render. Not sure what’s going on.

Wait… Look in the Outliner. Is the camera turned on for the object? if not, even if it shows in the editing window, it WON’T show up in the render.

Yes in the outliner object pannel the camera is on for the object, and unhiding doesnt solve it.
Also keep pressing unhide and i notice that blenders memory consumption changes (although everything already was unhided).

If in edit mode and using cycles render its also not displayed.
But in texture mode or in material or solid it is visible.

I tried to unhide it by python script, no effect either.
Tried other beta blender version also no effect.

did you check you camera limits ?

happy bl

Post the blend file,you probably would have had the solution about now if we had access to the file.

From the symptoms you describe there must be more than one issue - unless it is a bug indeed.

If the object is visible in Object mode, etc. but not in Edit mode, you must have hidden the geometry in Edit mode. The hiding/unhiding commands are context sensitive - Alt-H in Object mode will not unhide geometry that has been hidden in Edit mode! You will need to explicitly do the Alt-H in Edit mode to change that.

But hiding geometry in Edit mode will not influence visibility in Cycles renders. So there must be another effect at play. One of the “classics” is the duplication mode - make sure it’s set to “None”:

As for the increasing memory consumption on pressing Alt-H - that’s imho just the undo system monitoring your keyboard commands (as useless as they might be in the given context - like unhiding already visible meshes). And I think I can prove that: If you set the number of undo steps in the user preferences to 0, the memory increase on hitting Alt-H will stop.

The object is visible both in edit and object mode if i don’t put on the screen to cycles render.
So my object is there i can edit it, but it wont render in cycles (renders in BGE too, renders texture edit wired mode etc) but not in cycles render mode and neither in final cycles render.
Its not related to its cycles material, as if applied to other objects they renders just fine.
And while i guess its caused by pressing H and undo-ing the hide action makes effect for final cycles render
Maybe something else has happened, but then not intentionally perhaps i hit an unknown key combo.
But i wasnt realy altering mesh setting trough the object property pannels, so didn change duplication (but thanks for that tip).

and glad you explained C too.

I’m sorry but i cannt share a model design in this case, its for my work non released product designs i may not put on the internet not even a rendered picture of it (if it would have worked), or the 3d model i geuss you can understand why this is. I’d be happy to share it if it was one of my personal blender files but this one i just cannt do that.
I rather keep my job and feel happy that i can use blender with my job sometimes. (not all the time because i’m doing mostly other stuff programming etc sometimes i have my blender periods which i enjoy a lot at work. I work in small industrial automation company)

can you like cut one ob in 1/2 then make a small sample file so we can test it !

otherwise it’s gone be very difficult to helo you here!

happy bl

Did you check this? You never said…

nope last one was just as in my file.

Now i’m trying to remove everything from the blend file except a part of the problematic object, and deform it beyond recognition. As for one thing learned so far it wasnt caused by other objects, or modifiers its somewhere else. Its still invisible in cycles mode.

Now i also need to remove all textures from this file before i can post it here; how do i do that ?.

its a bit late i got to remove everything again because i forgot for some realisitc effect i had fog.
In the cycleserror.blend the fog was to much, when removed my object apeared…
HOWEVER this didnt solve it for the main blend file removing fog didnt solve anything there; and strangly then why only 1 mesh.

So it could be some effect of something else modifier / object / ??? / that has an effect.
I got to remove everthing again step by step.
I do this step by step since then i might also find cause perhaps.

i do the remaining removal this weekend.

ok well i couldnt resist… i deleted other meshes, not much happened for quite a while.
Until… i deleted some bones from the machine mesh… after deleting them the cycles material became visible again.

Now how weird is that ?.

I dont see the normal blender relations in here; maybe i deal with file coruption… i beter disable compress savings, get my meshes out of it and create a new file. unless someone says…oh just pres…xxxxx + shitf or so