Objects not visible after DXF import

Hi Blender gurus.

Sorry for asking dumb questions, but I’m new to Blender and have been struggling with importing a DXF file with some land contour information in it from a survey. I can successfully import the file OK, but I can’t see any objects. I can see the objects in the outliner, and when I look at the object properties, most of the objects have a location of X=311 metres, Y=approximately 6 kilometres. I’m assuming these larger distances are why I can’t see them initially. Is this correct? I don’t seem to be able to zoom out enough to see them.

Can anyone tell me what to do so I can see the objects?

If it is not possible, can I move all of the objects closer at the same time so I can see them? I tried selecting all objects and transforming them Y = -6KM, but it didn’t seem to work.

I don’t know why the original file was set up that way. I converted it from a DWG with ODAFileConverter.

Any help would be greatly appreciated.

I am unable to upload the file I’m working with as I am a new user.

Many thanks.

Hey Aaron,

I’m assuming your in Blender 2.80 ( 2.79 doesn’t seem to Importing dxf’s).
If you’ve imported this geometry into a new Blender file the default max viewport clipping is 1km (1000m):

which if your meshes are beyond will not show. Simply increase this value to say 20km if your scene is 6km away. This also affects the Top/Front/Back etc views too.

Also check that the meshes are not in a collection that is set to non-visible ( see above).

Finally, it is possible for the geometry to be ‘empty’ with no associated data ( or it failed to import correctly), the best way to check this is to import another dxf and see if that works, so, here’s a 5km cube export as a dxf from Blender:

Cube_5km.dxf (3.2 KB)

which is a small download of a huge object :grinning:

and finally what it should import like when you set the clipping values appropriately:

Cheers,
Dj

Hey Dj.

Thanks for your response. I forgot to mention I’m using Blender 2.79b on MacOS Mojave 10.14.3. Sorry!

My objects are not set to non-visible. That focal length end sounds like it could be my problem though.

For the life of me I can’t find it in my version. Is it somewhere different in 2.79b?

Aaron

Hey Aaron,

it’s in the same location on the right-hand panel:

When I originally responded to your post I had assumed you were using b2.79, but in making the 5km cube I realised I could not import the dxf I had built to export. So I then assumed you must be on b2.80 which does import dxf. So now I’m curious how you’re able to do this in 2.79, because if your using a 3rd party add-on then this might be an issue to consider.

Additionally, in b2.79 there is a problem with the viewport drawing huge meshes ( as in dimensions not poly count), in the image above, the cube ( again 5km) has very significant artifacts - the stripes at the bottom vertex and the ‘missing’ face on the left - that’s a display issue. Rotating the cube causes the entire thing to flicker with random stripes and faces blinking in and out of visibility. If your geometry is more elaborate it might simply fail to show you anything consistent.

You might want to consider downloading b2.80 and trying to import your dxf into that. If that succeeds you can then export it as an .OBJ or .FBX, though that won’t mitigate against b2.79 not being able to draw your mesh cleanly to the display. Blender 2.80 doesn’t seem to suffer the same problem :slight_smile:

Dj.

I didn’t have View properties showing which is why I couldn’t see it.

I simply enabled the add-on ‘Import-Export: Import AutoCAD DXF Format’ to do the import. Increasing the clip end value didn’t seem to solve my problem. I still can’t see the objects. I wonder if it’s a problem with the add-on? I might try 2.80 as you suggest before investing any more time on it.

Interestingly, I had problems importing Sketchup files as well - both DAE and OBJ formats. I just couldn’t see any objects after the import. Multiple Sketchup files behaved the same way. I wonder if it’s related?

Thanks so much for your help.

All of my importing problems (Sketchup and DXF) seem to have disappeared with Blender 2.8. Thanks for the tip.

1 Like