Ocean: Why do Viewport and renders show (very) different stages of the simulation?

I have an ocean simulation.

Let’s say the waves are 1 meters high at frame 1 in the Viewport, in solid mode. But when I render, they’re suddenly 2 meter.

Why is that, and is there any way to change it so I get exactly the same render as the image I know from the Viewport?

EDIT: It may be more accurate to say that the entire ‘height’ of the ocean (as opposed to the height of the waves) is displayed differently (much higher) in the renders.

But we don’t have your demo .blend file to review

I don’t own the project, so I can’t upload it for copyright reasons.


any other modifiers on the objects ? Is there a displacement map in the shader ?

Thank you for your reply. No, no displacements, but I know what the problem is now - or to be more precise, I know it isn’t related to Blender:

I just did a render in Cycles and that came out completely correct. So the problem has to do with the external render I’m using, and I’m going to talk to those guys instead.

I should’ve tried this before posting here, but I simply couldn’t imagine that a render engine that I completely trust could mess up like this.

Okay. Make sure you come back and write what was going on when you figure it out, in case someone has the same problem ! :wink:


I will! I’ve started a thread so I hope somebody knows the answer. This is really annoying, and I’ve tried every setting I can think of. I can’t even imagine why a render engine can change something like this…

then it looks difficult to define. ok make it half meter and then render… may you find 1 meter :wink:

… in case anybody’s using Octane Render, I just made a little ocean test here. Try it…

I’ll attach Viewport and Render screenshots as well. As you can see, there’s an additional wave in the background of the render that isn’t present in the Viewport, and the cube is almost covered in water in the render.


OceanExperiment.blend (455 KB)

Hi again,
I’d just say that I’ve asked the Octane forum, and I’m pretty sure now that there’s no way to solve the problem. Octane is a nice render, but the Blender version is not really supported anymore and the forum is more or less dead now.

Does your ocean object have a scale factor !=1.0? If so, try applying scale and rendering. You may have to adjust your sim parameters but it may give the results you want. Just a thought.

Hi chipmasque,
Thank you very much for your reply, you’re brilliant! Applying scale, location and rotation did it!

However, that opened up another can of worms: :slight_smile:

I had moved the ocean to another location to begin with for a reason - so now it is placed at a ‘wrong’ location (and it’s obviously not possible to move it to ‘right’ location again; that just recreates the problem). And the rest of my project can’t be moved to that new ‘wrong’ location for the exact similar reasons…

Does it work to Apply Scale alone, or only Scale+Rotation? I rarely Apply Location for the very reason you state.

Yeah, don’t apply location!

That sends the objects origin point back to the centre of the 3d space! just use the apply Rot&Scale in future. :smiley: