Octane for Blender vs. Cycles Render Testing Help

I got really curious about Octane looking at all the amazing images made with it recently but as I started testing it (the demo) I kept thinking that it wasn’t nearly as fast as I was expecting. I’m doing a simple test scene with basic objects (one of which emits light). I’m using a basic HDRI to do the rest of the lighting and currently, Cycles can render this better in less time. What am I doing wrong in Octane?

Here are my results…


If you share the .blend I can take a look at it. :slight_smile:

Thanks! Here are the 2 files…

Oh and you’ll want the luxo jr hdri…

That is really weird, I think there is a bug somewhere. By far most of the time is taken in the “evaluating render target” phase of the render. I’m not sure what the plugin is doing to make it so slow. I’m going to post the question on the plugin forum and see what the devs say about it. I have noticed this slow down on the recent versions of the plugin as well with my own projects.

My times to render on my 980 are as follows:

Cycles: 1:05.07
Octane: 1:38.15

But if you take the time for the evaluation off of the Octane time it ends up at around 40 to 50 seconds.

Some tips to get better render time:

Don’t use PMC unless you really need it, like for caustics or in a dark enclosed space. Octane is doing a lot more calculations than Cycles in this mode so naturally it will be slower. I switched your scene to path tracing and it spead it up considerably without changing the rendered image.

Don’t use Alpha Shadows unless you need them, it slows things down as well.

I upped the the caustic blur setting to 0.1 as it helps with noise and fireflies especially with glossy surfaces.

I set the coherent ratio to 0.5 and the path term power to 0.3, these can really speed up the render.

I also removed the Cycles nodes and Blender lights as those can slow things down a bit I have noticed.

Thanks so much! I’m going to try out your changes. Hey, can you provide me a good Octane Skin shader to play with? I don’t have access to the materials area that you guys do who own Octane. Most of my work deals with characters so I want to do some more tests with hair and skin… hair I got working right away.

Thanks again for all the tips and let me know what you find out from the Octane forum. I’m very seriously considering this purchase but want to make absolutely sure I’m doing the right thing. I’m going to test this stuff again on my multi-GPU rig tonight.

I will have to look around for a skin shader, let me see what I can find. Another tip for scenes like this is that all the cubes and spheres, etc. should be instanced and then in the object tab for each one the mesh type should be set to scatter. I think that would speed things up 100 fold.

Ok here is one, it’s pretty complex. :slight_smile:

skin.blend (663 KB)

Yeah but I’ll never render a scene like this for reals. This was just a test… but yes, I should be more efficient at making these scenes.
Thank you for that shader! I’m going to dl it right now and play around.

Can you tell me a little about rendering frames (animation) with Octane? I read somewhere that it’s difficult. Is that true? It seems like you just hit “Render Active Scene” and let it go to town just like Cycles. Let me know if this is not the case. I don’t see anything missing in the settings… it’s got motion blur and lens effects. Everything looks in order.

Should work fine, I usually just press the render animation button. :smiley: The old python plugin could have some issues with animations, but I don’t remember it being overly difficult.

I’m testing on my new GPU machine now and the file I sent you renders at 0:45 in Octane. Just removing the sun gave me back an entire second to 0:44. I changed the kernel to path tracing and set the other settings and am now just under 0:20 which It think is really good compared to Cycles 0:31. I’ll play with the skin on a character and do more tests there and might tackle a larger indoor scene that I have but it will take a lot of time to set that up properly.

Does the evaluation happen every frame or do you get some of that back with multiple frames?

OMG… what is crazy impressive is the viewport! I’m not sure what Cycles uses in the viewport (like if it’s even using GPU at that point) but Octane is lightning fast there.

Edit* Well I’ve obviously never tested Cycles viewport with multiple GPUs because it’s pretty darn fast also. Both are crazy impressive!

Excellent! :slight_smile: I’m glad it’s working, yes the viewport is awesome cool, almost as good as Octane stand alone. The plugin tries to cache on the server as much as it can so you can make changes interactively. I don’t know how much caching the full render does, maybe none?

Edit: now that I think about it the full render does cache but it’s tied to the mesh type. It’s very important for animations that you set it correctly as the server only gets updated if it needs to be.

Well I can definitely say that the viewport is quite a bit faster than Cycles. Cycles is really nice with multiple GPUs but Octane is crazy fast which is fantastic for iterating. I think those light emitting objects might through it for a loop because everything else goes really really fast.

I’m trying to work with that skin shader but it’s being difficult. I’m not seeing very good results right now. I’ll keep at it and post some more time tests with a character this time.

Cool, looking forward to see what you come up with. :slight_smile:

I cannot get that skin shader or anything sss to work at all. I can place a diffuse shader in place of that skin with the same color and it gives me the exact same render so something is wrong somewhere. Grimm, do you work in Blender’s viewport or do you export your model to Octane?

There are a couple of things you can check. The first thing to check is the scale on the SSS node. Because Octane is a PBR renderer where everything is calculated from real world scales and there is no “one size fits all”, make sure that the scale matches your model. The other thing to check is that you have enough samples defined in the viewport to show the SSS. It’s been awhile since I have played around with SSS, but I seem to remember that it will take more than 100 samples for it to start to show.

Aha! I figured it out. I was on the “Direct Light” kernel. Just switched it over to Path Trace and can finally see the SSS. :slight_smile:

Excellent, yep that would do it too. :smiley:

If you disable them for octane, disable them for cycles aswell (under light paths -> shadows)

Sorry, pre-morning coffee brain fart.